Reply
 
Thread Tools Display Modes
Old 08-15-2015, 01:27 PM   #11
Senior Member
 
Join Date: Mar 2012
Posts: 149
My Sunseeker has a Dometic 310 toilet, if you have to replace the seal on this toilet it can be done without removing the toilet. Go to dometicusa.com to download the manual. Good luck
__________________

__________________
edcronin01 is offline   Reply With Quote
Old 08-15-2015, 07:33 PM   #12
Member
 
alsimmon11's Avatar
 
Join Date: Apr 2011
Posts: 71
Toilet water

The black seal around the opening is dry or worn. Turn off the water, dry the seal off and put some Vaseline around the under side of the seal. This should seal it enough to hold water.
__________________

__________________
alsimmon11 is offline   Reply With Quote
Old 08-16-2015, 11:55 AM   #13
Junior Member
 
Join Date: Jul 2015
Posts: 6
We drain each time but the anti-freeze makes sense. It's under a year old so luckily it should cover under warranty and they can fix it
__________________
maryferguson is offline   Reply With Quote
Old 08-18-2015, 10:52 PM   #14
Member
 
Join Date: Nov 2011
Posts: 85
We have had the same problem. I used plain plumber's grease and it worked for a while. But you had to "flip" the foot leverThis last time I got plumber's silicone grease (because I couldn't find my old grease) and applied it to the edges as described above and also packed it down toward where I presume the hinge for the ball is and now the ball shuts more smartly and there is no leak after a seven day trip with seven people.


Sent from my iPhone using Forest River Forums
__________________
budblack is offline   Reply With Quote
Old 08-20-2015, 04:01 PM   #15
Junior Member
 
Join Date: Jul 2015
Posts: 6
That sounds GREAT! I hope it would still be under warranty since we've only had it a little over a year?
__________________
maryferguson is offline   Reply With Quote
Old 08-22-2015, 01:46 PM   #16
Junior Member
 
Join Date: May 2015
Posts: 19
Second related issue

I have the same problem, but different issue on my 2015 sunseeker 3050s. Our issue is that one of the black clips that hold the flapper to the sides of the tube to the black tank fell into the tank. Not the flapper arm pops out of the holder, which breaks the seal to the bowl. I would check this as well if you also have a new rig.
__________________

__________________
Jtf320 is offline   Reply With Quote
Reply

Tags
water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:27 PM.