Thread Tools Display Modes
Old 08-20-2015, 06:46 PM   #1
Senior Member
Sunnyfun's Avatar
Join Date: Aug 2013
Posts: 168
Wire came off on sunseeker 3050 slide over ride box

Slide was not getting any juice after long month trip. During trip it worked like a charm. Went to over ride box tried it and nothing. Then noticed on right hand side of box there are two wires with yellow tips and one of them had come loose, was going to put it back on, but, when touched to prong there were sparks, so did not do it, has anyone had this happen and if so what did you do. I hate to take it to the dealer unless I have to. Thanks for any help !
Sunnyfun is offline   Reply With Quote

305, slide, sunseeker

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:22 AM.