Reply
 
Thread Tools Display Modes
Old 10-03-2014, 10:49 AM   #11
GM
 
bclemens's Avatar
 
Join Date: May 2011
Location: Elkhart, IN
Posts: 7,088
Check valve
__________________

__________________
PLEASE do not send questions via Private Message. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only. Our owners manuals are available online and via iPhone/Android Apps. http://www.dynamaxcorp.com/OnlineManual.aspx
bclemens is offline   Reply With Quote
Old 10-07-2014, 05:04 PM   #12
Senior Member
 
Join Date: Sep 2012
Location: Driftwood, Texas
Posts: 105
where is the check valve?

i just tore the compartment apart and can't find it... hose runs up into a 3" black pipe with all the other hoses - no sign of any valve on the black tank flush line. is it on the tank itself? photo, please!
__________________

__________________
tommyb is offline   Reply With Quote
Old 10-07-2014, 05:19 PM   #13
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by tommyb View Post
where is the check valve?

i just tore the compartment apart and can't find it... hose runs up into a 3" black pipe with all the other hoses - no sign of any valve on the black tank flush line. is it on the tank itself? photo, please!
Right at the hose connection.
Or should I say just behind it.

Turbs
__________________
TURBS is offline   Reply With Quote
Old 10-07-2014, 06:08 PM   #14
Senior Member
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 9,505
Carefully take out the washer with screen and you'll fund the check valve pictured below. You might try pushing in the white piece in the middle to see if it's stuck. Just stand off to the side when you do.

Click image for larger version

Name:	check valve.jpg
Views:	126
Size:	30.9 KB
ID:	64294
__________________
Wiscampsin is offline   Reply With Quote
Old 10-07-2014, 06:33 PM   #15
Senior Member
 
Join Date: Sep 2012
Location: Driftwood, Texas
Posts: 105
that is absolutely not on my solera. i removed those three screws you see in the photo, then the clip behind. i reached behind the panel and removed the compression nut. i held the hose fitting in my hand, peeked through it, and it is a clear hole... no check valve. i examined the hose, and traced it up into the 3" pipe, looking for an inline check. there is nothing in the compartment... and yet water will not enter the black tank. the mystery continues....
__________________
tommyb is offline   Reply With Quote
Old 10-07-2014, 07:18 PM   #16
Senior Member
 
EJM4's Avatar
 
Join Date: Jul 2012
Location: Mechanicsburg - PA
Posts: 512
Quote:
Originally Posted by tommyb View Post
that is absolutely not on my solera. i removed those three screws you see in the photo, then the clip behind. i reached behind the panel and removed the compression nut. i held the hose fitting in my hand, peeked through it, and it is a clear hole... no check valve. i examined the hose, and traced it up into the 3" pipe, looking for an inline check. there is nothing in the compartment... and yet water will not enter the black tank. the mystery continues....

Same situation in my motorhome. It used to work. I chalk it up to something (paper) getting dried on the nozzle inside the tank.
__________________

__________________
Earl
2013 Berkshire 390BH / 360hp
EJM4 is offline   Reply With Quote
Reply

Tags
black, black tank, black tank flush, tank

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:27 AM.