Reply
 
Thread Tools Display Modes
Old 08-05-2013, 11:36 AM   #1
Junior Member
 
Join Date: Aug 2011
Posts: 29
Can't Start!!

Help! Just returned from weekend camping, unloaded Solera and went out to start it so I could refuel. No sound when key was turned, but EVERY indicator light came on! The engine battery is not discharged, but I am in process of charging it (was 80%) just in hopes this will help. Any ideas please before I call for service - I'm pretty new to this RV thing, so it could be something simple and embarrassing.
__________________

__________________
RSolera is offline   Reply With Quote
Old 08-05-2013, 11:39 AM   #2
Member
 
Join Date: Jul 2013
Location: Dublin, NH
Posts: 30
Is it fully in park?
__________________

__________________
pcmdnh is offline   Reply With Quote
Old 08-05-2013, 11:45 AM   #3
2018 FR3 30DS
 
Join Date: Mar 2011
Posts: 178
Check fuse number 23 in the fuse panel on the firewall under the steering column. Some Soleras had a 20 amp fuse and it should be a 25 amp fuse. Mine did the same thing as yours and that was the problem. If the fuse is blown, replace it with a 25 amp fuse.
Also, sometimes my engine won't turn over but it has a clicking sound. Don't know what this is but I am gonna take to MB service to get it fixed. I can keep turning the switch off and on and sooner or later it will crank.
Hope this helps
__________________
Slow_movin is offline   Reply With Quote
Old 08-05-2013, 12:05 PM   #4
Junior Member
 
Join Date: Aug 2011
Posts: 29
Can't start!

Tried rocking RV and made sure it was fully in Park - it was. Then followed SlowMovin's advice. The #23 fuse was blown and as suggested, I replaced it with a 25amp fuse. The engine started right up!! Thank you so much!!!
Now, I have to wonder why Forest River would put a 20amp there and what could be the cause of that fuse blowing???
__________________
RSolera is offline   Reply With Quote
Old 08-05-2013, 12:15 PM   #5
Senior Member
 
Displaced2's Avatar
 
Join Date: Feb 2013
Posts: 309
I think that part of electrical is MB and not Forest River.
__________________
Displaced2 is offline   Reply With Quote
Old 08-05-2013, 01:43 PM   #6
2012 Solera 24S
 
Join Date: Jun 2013
Location: NW Illinois
Posts: 107
This is a Mercedes issue and not Forest River, I had to do the same to mine less than 1 day after I brought it home.

Haven't had a problem since.
__________________
Nats is offline   Reply With Quote
Old 08-05-2013, 01:45 PM   #7
Senior Member
 
Taylorgso's Avatar
 
Join Date: Jan 2013
Location: Greensboro, NC
Posts: 775
Quote:
Originally Posted by Slow_movin View Post
Check fuse number 23 in the fuse panel on the firewall under the steering column. Some Soleras had a 20 amp fuse and it should be a 25 amp fuse. Mine did the same thing as yours and that was the problem. If the fuse is blown, replace it with a 25 amp fuse.
Also, sometimes my engine won't turn over but it has a clicking sound. Don't know what this is but I am gonna take to MB service to get it fixed. I can keep turning the switch off and on and sooner or later it will crank.
Hope this helps
Gotta file this one for future reference!
__________________

__________________
Ed (N4RWU) & Becky Taylor
Mistie (Walks 4-down)
Greensboro, NC
Taylorgso is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:02 PM.