Reply
 
Thread Tools Display Modes
Old 06-21-2013, 11:52 AM   #1
Senior Member
 
hkreck's Avatar
 
Join Date: Apr 2012
Location: Iowa
Posts: 1,190
CO detector

I went outside last night at about 1:30 A.M. and I heard a smoke alarm going off. Turned out to be the CO detector in my Solera. I've had this happen before and I remember some comments about it on the Forum. Any one else have problems with their CO detectors.
__________________

__________________
Henry & Tena
2013 Solera 24S
The Great Escape
hkreck is offline   Reply With Quote
Old 06-21-2013, 12:43 PM   #2
Senior Member
 
Taylorgso's Avatar
 
Join Date: Jan 2013
Location: Greensboro, NC
Posts: 775
Quote:
Originally Posted by hkreck View Post
I went outside last night at about 1:30 A.M. and I heard a smoke alarm going off. Turned out to be the CO detector in my Solera. I've had this happen before and I remember some comments about it on the Forum. Any one else have problems with their CO detectors.
If it operates like the one I have at home, the detector is designed to sound an alarm when battery is low. My understanding is that the detectors are wired directly to battery, not through the batt. disconnect. I have no idea at what charge level they sound, but you may want to check batteries (charge & electrolyte level) next time you hear it go off.

If it's going off and battery level is good, I'd presume you may have a bad detector.
__________________

__________________
Ed (N4RWU) & Becky Taylor
Mistie (Walks 4-down)
Greensboro, NC
Taylorgso is offline   Reply With Quote
Old 06-21-2013, 01:14 PM   #3
Senior Member
 
papap's Avatar
 
Join Date: Apr 2011
Location: Southwest Louisiana
Posts: 729
Switch

I ended up putting mine on a switch. Only turn it on when we head out to go camping.
__________________
2016 Forester 3171DS
Work 28 and 28 around the world.
Camp every chance we get

papap is offline   Reply With Quote
Old 06-21-2013, 01:40 PM   #4
Senior Member
 
hkreck's Avatar
 
Join Date: Apr 2012
Location: Iowa
Posts: 1,190
Ed

Thanks for the idea but I've noticed that it only does it when I have it plugged in. right now it's plugged into and shore line from my garage. I haven't noticed it go off when on battery alone?
__________________
Henry & Tena
2013 Solera 24S
The Great Escape
hkreck is offline   Reply With Quote
Old 06-21-2013, 03:58 PM   #5
Senior Member
 
Taylorgso's Avatar
 
Join Date: Jan 2013
Location: Greensboro, NC
Posts: 775
Quote:
Originally Posted by hkreck View Post
Ed

Thanks for the idea but I've noticed that it only does it when I have it plugged in. right now it's plugged into and shore line from my garage. I haven't noticed it go off when on battery alone?
Now that IS weird! It does sound like you may have a faulty detector. Should be in warranty.
__________________
Ed (N4RWU) & Becky Taylor
Mistie (Walks 4-down)
Greensboro, NC
Taylorgso is offline   Reply With Quote
Old 06-21-2013, 05:11 PM   #6
Senior Member
 
hkreck's Avatar
 
Join Date: Apr 2012
Location: Iowa
Posts: 1,190
I may have to explore that option.
__________________
Henry & Tena
2013 Solera 24S
The Great Escape
hkreck is offline   Reply With Quote
Old 06-21-2013, 05:24 PM   #7
Senior Member
 
kingwood390bh's Avatar
 
Join Date: Nov 2011
Posts: 270
I had the same problem. Even with new batteries it chirped. I found one at Lowes for $19. They used to be $50
__________________
kingwood390bh is offline   Reply With Quote
Old 06-21-2013, 05:45 PM   #8
Senior Member
 
trudinator's Avatar
 
Join Date: Mar 2011
Location: Wisconsin
Posts: 1,326
Ours did the same thing. It was defective. The factory had a bad bunch of them, but they should have run through those by now.
__________________
2012 Rockwood 8293RKSS
2006 Dodge Ram 2500 5.9L Cummins Turbodiesel 4x4; 2012 Ford Escape 4x4. 3 very pampered cats.
Days camped: 2011: 61; 2012: 66 Days; 2013: 69;2014: 68 2015: 90 Days camped 2016: 34
trudinator is offline   Reply With Quote
Old 06-22-2013, 06:46 PM   #9
Senior Member
 
hkreck's Avatar
 
Join Date: Apr 2012
Location: Iowa
Posts: 1,190
trudinator

What did you have to do to get it replaced?
__________________
Henry & Tena
2013 Solera 24S
The Great Escape
hkreck is offline   Reply With Quote
Old 06-23-2013, 06:31 PM   #10
Member
 
Join Date: Sep 2012
Location: Antioch
Posts: 55
Mine goes off too when on shore power and when 90 plus degrees outside.
__________________

__________________
2013 Solera
Antiochrich is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:37 PM.