Thread Tools Display Modes
Old 10-26-2012, 08:57 AM   #31
bclemens's Avatar
Join Date: May 2011
Location: Elkhart, IN
Posts: 5,056
Originally Posted by reinerka View Post
What year is the Solera?

On our 2011 it went bad and it was the camera itself. A simple camera replacement solved the issue quickly. The shop (Toscano) sent a guy over to replace it - love that kind of service. Nothing was wrong with the cables when he checked them out - at least issn our case.

I doubt it is the cabling on yours as well. The cable don't cone out as he quickly found as well. He even improved some connections...

Camera or monitor that went bad?

PLEASE do not send questions via Private Message, my inbox fills up too quickly. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only (VIN, Contact info or things you do not want the public to see).
bclemens is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:59 PM.