Reply
 
Thread Tools Display Modes
Old 07-12-2014, 09:32 AM   #1
jsk
Senior Member
 
Join Date: Mar 2011
Posts: 124
A Little Help Please

First - in April we bought a Progressive portable 50a surge protector(EMS 50 PTC). It worked good first trip out and second trip it did not power up. Sent it in for repair and got it back. Tried it at home and all was good. We went on a 2 week trip and got to CG and it did not power up again. No lights on the display. After getting home I tried it again and nothing. After about an hour it came on. I would like to call tech support but the unit is working correctly. At times it does say PE10 which is replace surge. When I sent it in for repair the first time it had moisture in it.

Second - since April my heating element keeps going out. The gas side works fine. When dewinterizing the by pass valve failed. I thought water was in the tank by turning on faucet but did not check relief valve (lesson learned). Now the element lasts only a few days before going out. How can I solve this problem? I am wondering if water is exiting the tank faster than it is coming in. On out last trip the element went out during showers that were close together.

Thanks for any suggestions.
__________________

__________________
2012 F-350 SRW 6.7
2012 Sabre 34-REQS
jsk is offline   Reply With Quote
Old 07-12-2014, 10:10 AM   #2
Senior Member
 
Evereddie's Avatar
 
Join Date: Feb 2013
Location: Pfafftown NC
Posts: 2,064
Water heater: Don't seem possible that water could leave faster than it comes in since it is the incoming water that pushes out the water heater water. Heating element is at the bottom of the tank and would think that once the water was flowing it would be hard for it to get uncovered. I would look for a possible high voltage situation. Are you going to the same campground? Do you have a voltmeter other than the Progressive unit? Can you duplicate the heating element problem at home?
__________________

__________________
Evereddie is online now   Reply With Quote
Old 07-12-2014, 01:15 PM   #3
jsk
Senior Member
 
Join Date: Mar 2011
Posts: 124
I agree about enter/exit water but had to ask because you never know. I have had elements fail at 3 different locations. At one of those locations the Progressive unit was working and hooked up. I do have a meter at home just not sure what to check.
Is there a board internally that I can not see or get to without pulling out the unit?

Thanks
__________________
2012 F-350 SRW 6.7
2012 Sabre 34-REQS
jsk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:33 AM.