Reply
 
Thread Tools Display Modes
Old 11-26-2010, 01:37 PM   #1
Senior Member
 
Join Date: Sep 2010
Posts: 238
Damaged trailer plug, now no power!

Ok yesterdasy when arriving at the camp ground i pinched in two pieces, i have used plastic splices and crimped them all together.

Not a big deal but perhaps related i can not run anything but my electric jack off the battery,

the biggest issue is i have electric brake power and driving lights but no tail and or turning lights.

Please help

i am at a loss for ideas the in line fuses i found by the battery and under the front are good. The trucks signals work and the bulbs are not burnt out.
__________________

__________________

2009 F150 SCREW4x4 Prodigy P3 and tow package Valley WDH and dual anti sway
2006 Party Barge 21 90 Merc Optimax
2011 RockWood 2702 SS arrived 11.10.2010
nights camped 2010 6
threegr8katz is offline   Reply With Quote
Old 11-26-2010, 01:43 PM   #2
Infractee
 
Join Date: Aug 2010
Posts: 794
I believe ford has a seperate fuse for trailer lights, turn signals etc. I think there is also an isolator as eell, check your owners manual on that
__________________

__________________
RhoZeta is offline   Reply With Quote
Old 11-26-2010, 01:55 PM   #3
Infractee
 
Join Date: Aug 2010
Posts: 794
Look on page 315 or therabouts in owners manual, power distribution panel under hood, all seperate relays for each trailer function. Lights, stop lights, turn signals, brakes, battery charging etc.
You may try swapping some of the relays from the working circuit to the inop circuit and see if that fixes it.
__________________
RhoZeta is offline   Reply With Quote
Old 11-26-2010, 02:00 PM   #4
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Each item in the pigtail has its own fuse in your fuse block.
Of additional concern is the lack of DC power inside the camper while on TV power.
There is a "resettable" current limiter that separates the camper from the TV somewhere in your camper. On my 5th wheel, it is a red rubber covered square under the pin box.

I have heard from the TT crowd that the TT has one near the battery and it has a small reset button on its side.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 11-26-2010, 05:40 PM   #5
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Quote:
Originally Posted by threegr8katz View Post
Ok yesterdasy when arriving at the camp ground i pinched in two pieces, i have used plastic splices and crimped them all together.

Can you clarify further...what got pinched, what location, etc. Did everything work okay the last time you used the camper?

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 11-26-2010, 06:15 PM   #6
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
check the splices. i had a problem with turn signals/brake lights not working and traced it back to the splice under the truck. i have a 5th wheel and the in bed socket was spliced into the origional equipment wiring.
when i removed the light bulb at the trailer and checked voltage, all was normal. with a bulb in, it wasn't. splice was making contact but not enought to carry a load.
__________________
jimh is offline   Reply With Quote
Old 11-26-2010, 08:06 PM   #7
Senior Member
 
caper's Avatar
 
Join Date: Jul 2010
Posts: 1,973
My 08 F150 fuse panel is passanger side beside door. There are seperate fuses for the truck and trailer lights. That would be a good place to start if your trailer lights are not working. It is a.p.i.a. to get at the fuses.
__________________
caper is offline   Reply With Quote
Old 11-26-2010, 09:31 PM   #8
Senior Member
 
Join Date: Sep 2010
Posts: 238
Ok update, the trucks fuse panel under the hood had a couple fuses which I replaced,
all the splices are 100% all the lights work now.... Turn signals, brake lights, running lights and electric brakes......

The only problem now is the battery............ If the trailer is not plug in to 30 amp and i try to use the battery for lights pump what ever nadda///////////

before pinching the pigtail from the trailer to truck we used the pump and lights via the battery...........

I have check the fuse at the

battery..good
fuse in front of junction box...good
fuses and brakers at fuse panel all good.....

The pinch really has us stumped/

any new and additional thoughts

this is our first outing other then having it delivered to the house and it sitting in our driveway hooked up to amp
__________________

2009 F150 SCREW4x4 Prodigy P3 and tow package Valley WDH and dual anti sway
2006 Party Barge 21 90 Merc Optimax
2011 RockWood 2702 SS arrived 11.10.2010
nights camped 2010 6
threegr8katz is offline   Reply With Quote
Old 11-26-2010, 11:29 PM   #9
Senior Member
 
MotocrossCamper's Avatar
 
Join Date: Nov 2010
Posts: 653
There should be no reason why pinching your trailer lights would affect your battery power for the camper. I ripped mine off once and the 12volt system in the camper still worked fine. There is no way the battery disconnect got switched off is there? What does your information center say on the charge of the battery? Does it say it's full?

Another thought, on our Coachmen we had a few outlets that ran off of a converter that drew off the battery, one of those was a ground fault outlet and it tripped once killing all of the battery power inside the camper.
__________________
MotocrossCamper is offline   Reply With Quote
Old 11-27-2010, 07:35 AM   #10
Senior Member
 
Join Date: Sep 2010
Posts: 238
okay,

not sure if there is a gfi outlet tripped , several are working and only one that has the actually tripable lead..... I am guessing they are all linked to it.

I am sorry but I have no idea what the battery diconnect is where it is and how I could switch it on or off>?

yes the the information panel says that the battery has a full charge.....
__________________

__________________

2009 F150 SCREW4x4 Prodigy P3 and tow package Valley WDH and dual anti sway
2006 Party Barge 21 90 Merc Optimax
2011 RockWood 2702 SS arrived 11.10.2010
nights camped 2010 6
threegr8katz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:17 AM.