Reply
 
Thread Tools Display Modes
Old 09-30-2012, 09:46 AM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 4
Head lights not working

We went to leave last night and had no headlights! I checked every fuse I could find and all was good. Everything else is working including the rest of the lights on the exterior. Any ideas?
__________________

__________________
Glucas is offline   Reply With Quote
Old 09-30-2012, 10:07 AM   #2
Moderator Emeritus
 
Join Date: Nov 2008
Location: Winston-Salem, NC
Posts: 2,381
Hello, and to the forums. Hope you enjoy the stay, and learn a lot, and can teach others what you already know.

It would help a lot to now what we are talking about. Motor home, one can only assume. How about year, make, model. And might want to post in that section instead of general repair. Just hang in there, you'll get some answers. Don't forget the fuse.
__________________

__________________
LadyWindrider
2012 Ford F250 ext. Cab 4x4
2002 Jeep Wrangler Sahara
2008 Yamaha V-Star 650 Classic

2008 Work and Play 18LT
LadyWindrider is offline   Reply With Quote
Old 09-30-2012, 10:25 AM   #3
Junior Member
 
Join Date: Sep 2012
Posts: 4
Headlight Issue

Sorry, it is a 2009 Georgetown 35' SE with a V-10 Ford Chassis. I have inspected the ground on the upright and all seems ok. I have checked all the fuses and all are good. High beam indicator is on with no headlights or fog lights - all other exterior lights are working.
__________________
Glucas is offline   Reply With Quote
Old 09-30-2012, 10:53 AM   #4
Junior Member
 
Join Date: Sep 2012
Posts: 4
I am not sure what happened but all the lights are working except the drivers amber light. Switched bulbs and still not working on drivers side.
__________________
Glucas is offline   Reply With Quote
Old 09-30-2012, 11:31 AM   #5
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by Glucas View Post
I am not sure what happened but all the lights are working except the drivers amber light. Switched bulbs and still not working on drivers side.
Sounds like problem A was account of intermittent headlamp switch or relay.
Orange light socket corroded or single element bulb as to dual element. Socket will receive either. Dual elment if signal and marker
__________________
VinceU is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:03 AM.