Reply
 
Thread Tools Display Modes
Old 07-07-2014, 11:09 AM   #11
Senior Member
 
Cypressloser's Avatar
 
Join Date: May 2014
Location: Alberta - East of the Rockies, West of the Rest
Posts: 847

Sorry, the pics didn't show up in my previous post.
__________________

__________________
2013 RAM 3500 Dually Longhorn traded in
2018 RAM 5500 in the pipe
Riverstone Legacy 38RE, 960 Watt Solar, 6x6 Volt Battery Bank, Freedom SW 3012 Inv/Charger
Cypressloser is offline   Reply With Quote
Old 07-07-2014, 11:11 AM   #12
Senior Member
 
Cypressloser's Avatar
 
Join Date: May 2014
Location: Alberta - East of the Rockies, West of the Rest
Posts: 847
what the? this is a first.
Anyway, you can search Google for rv surge protector and rv voltage regulator.
__________________

__________________
2013 RAM 3500 Dually Longhorn traded in
2018 RAM 5500 in the pipe
Riverstone Legacy 38RE, 960 Watt Solar, 6x6 Volt Battery Bank, Freedom SW 3012 Inv/Charger
Cypressloser is offline   Reply With Quote
Old 07-07-2014, 12:53 PM   #13
Senior Member
 
Bilcin's Avatar
 
Join Date: Apr 2011
Location: Philadelphia PA
Posts: 385
Great! Thanks for the tips!
__________________
Bill & Cindy McKenna
Philadelphia PA
2015 Palomino Puma 32DBKS
2005 Ford Excursion 6 liter Turbo Diesel
Bilcin is offline   Reply With Quote
Old 07-07-2014, 12:58 PM   #14
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,840
If you use the search feature here you will find a bunch of information on surge protectors both hard wired and portable.
__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Old 07-07-2014, 09:14 PM   #15
Senior Member
 
Bilcin's Avatar
 
Join Date: Apr 2011
Location: Philadelphia PA
Posts: 385
Ok, well I unplugged the trailer from my house outlet, as well as the battery. I was hoping that the thermostat would reset upon me plugging the battery back in and unfortunately it didn't work. I put the fan on to low setting and about 5 seconds later I here a click but no fan.....I switch it to high setting and 5 seconds later the fan comes on at high speed. I then switch from high to low and the fan shuts off and 5 seconds later I here the click but no fan. Has anyone ever changed a fan or is this something only a qualified mechanic can do. BTW thanks for all suggestions!
__________________
Bill & Cindy McKenna
Philadelphia PA
2015 Palomino Puma 32DBKS
2005 Ford Excursion 6 liter Turbo Diesel
Bilcin is offline   Reply With Quote
Old 07-07-2014, 09:23 PM   #16
Senior Member
 
Join Date: Jun 2012
Posts: 6,738
There's probably a resistor that gets put in series with the fan when on low speed. If it burns out, then only high speed with run. The clicking is probably the relay that switches in the resistor.

This used to be how the fans in cars were controlled before "electronics." Fan speed was controlled by switching in different sized resistors for each fan speed. It was common to smoke the resistors and end up with only high speed.

Check for a burnt out resistor.
__________________
1988 Coleman Sequoia - popup (1987-2009) - outlasted 3 Dodge Grand Caravans!
2012 Roo19 - hybrid (2012-2015)

2016 Mini Lite 2503S - tt (2015 - ???)
2011 Traverse LT, 3.6L, FWD
2009 Silverado 1500 Ext Cab, 5.3L, 4x4, 3.73
2016 Silverado 2500HD Dbl Cab, 6.0L 4x4, 4.10
rockfordroo is offline   Reply With Quote
Old 07-08-2014, 08:58 PM   #17
Senior Member
 
RANGERBOB's Avatar
 
Join Date: May 2010
Location: Montrose, Colorado
Posts: 101
Yes, first major expenditure on our rig was a surge protector this after reading horror stories on this forum.
__________________
RANGERBOB is offline   Reply With Quote
Old 07-08-2014, 09:55 PM   #18
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by Bilcin View Post
Ok, well I unplugged the trailer from my house outlet, as well as the battery. I was hoping that the thermostat would reset upon me plugging the battery back in and unfortunately it didn't work. I put the fan on to low setting and about 5 seconds later I here a click but no fan.....I switch it to high setting and 5 seconds later the fan comes on at high speed. I then switch from high to low and the fan shuts off and 5 seconds later I here the click but no fan. Has anyone ever changed a fan or is this something only a qualified mechanic can do. BTW thanks for all suggestions!
Guessing the motor failed, there's most likely an open coil in the motor causing slow speed to be unavailable. It could be due to low voltage but not necessarily. People with very good help is Dometic, maybe call their 1800 line, have the model and serial if possible.
__________________
VinceU is offline   Reply With Quote
Old 07-08-2014, 11:15 PM   #19
Senior Member
 
Bilcin's Avatar
 
Join Date: Apr 2011
Location: Philadelphia PA
Posts: 385
I will try try the customer service route, thanks
__________________
Bill & Cindy McKenna
Philadelphia PA
2015 Palomino Puma 32DBKS
2005 Ford Excursion 6 liter Turbo Diesel
Bilcin is offline   Reply With Quote
Old 07-18-2014, 01:49 PM   #20
Senior Member
 
Bilcin's Avatar
 
Join Date: Apr 2011
Location: Philadelphia PA
Posts: 385
Just an update on my fan not working on low settings, Ok, before calling customer service, tried the low setting again ( I had already unplugged the battery and shore line to see if reset could work, it didn't) I hooked up the battery again on the shore line and it didn't work on low. I decided to put it on high settilineng then switch it to low, high setting, high shuts off, about 10 seconds later I hear the click for the low setting and again the fan did not go on. I tried it one more time from high setting too low setting, and this time the low setting worked? I then proceeded to turn it off wait 30 seconds and then selected the low fan setting and it works now, repeated this process three more times and all three times the low setting worked. I cannot explain this and all but if it works it works for me. I am going out purchasing the surge and voltage regulator for my next trip.
__________________

__________________
Bill & Cindy McKenna
Philadelphia PA
2015 Palomino Puma 32DBKS
2005 Ford Excursion 6 liter Turbo Diesel
Bilcin is offline   Reply With Quote
Reply

Tags
fan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:18 AM.