Thread Tools Display Modes
Old 05-19-2015, 12:26 PM   #1
Join Date: May 2015
Location: London Ontario
Posts: 29
Water heater gas problem Cardinal 37RX

Water heater(Suburban) is full( checked via relief valve).
On batteries only for now.
Turned on water heater and no action. No spark at piezo, no gas smell either.
Pressed the reset button (12v) and tried several times to restart with main switch . Nothing.
Noticed when changing the valve for de-winterizing there was a circuit board that had come adrift and was attached to the main service to the heater.
Wondering if this is the source of the problem before I go through circuit test routine.
I assume this board is the setting for temp. Any other function?
haven't been able to get back to the unit to check.
Any thoughts appreciated
4Sailrguy is offline   Reply With Quote

cardinal, gas, heater, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:20 PM.