Reply
 
Thread Tools Display Modes
Old 07-31-2014, 04:15 PM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 15
Air Conditioner smells

Anybody have issues with air conditioner blowing burnt rubber smell. Doesn't smell with fan running just when ac is running. Looked more simple wiring problems anybody know what I should be looking for. Still brand new and at its first campsite for two months only. Any help appreciated thanks. Tom
__________________

__________________
cybulskiet is offline   Reply With Quote
Old 07-31-2014, 05:14 PM   #2
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Compressor or wiring overheating? Remove cover and look/feel around.


Sent from my iPhone using Forest River Forums
__________________

__________________
VinceU is offline   Reply With Quote
Old 07-31-2014, 05:40 PM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
How can u get the compressor running without the blower?

TURBS

"SABRE OWNERS UNITED"
__________________
TURBS is offline   Reply With Quote
Old 07-31-2014, 08:51 PM   #4
Junior Member
 
Join Date: Mar 2014
Posts: 15
Looked around nothing suggests power issue. Everything works cold air fan etc just a bad smell almost like chemical.
__________________
cybulskiet is offline   Reply With Quote
Old 07-31-2014, 09:07 PM   #5
Senior Member
 
Join Date: Apr 2012
Posts: 3,155
Burning rubber or burning wires? You could get on the roof and take the cover off; have someone inside start the AC and see what you can see. Watch out for the fan... which I have seen an older unit that the fan didn't turn and got hot. I don't think it caused a bad smell, since its on the outside. I would take a quick look, but it sounds to me you need professional help... err... your unit needs professional help. Wolf.
__________________
WolfWhistle is offline   Reply With Quote
Old 07-31-2014, 10:42 PM   #6
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by cybulskiet View Post
Looked around nothing suggests power issue. Everything works cold air fan etc just a bad smell almost like chemical.
Could be contamination in the evap coil, the one inside. Can purchase cleaning compound in spray can (auto A/C) and flush it out. Very common problem in cars when AC laid up cool and full of moisture forms growth and odor. Not sure about chemical smell,
__________________
VinceU is offline   Reply With Quote
Old 07-31-2014, 10:52 PM   #7
Senior Member
 
Evereddie's Avatar
 
Join Date: Feb 2013
Location: Pfafftown NC
Posts: 2,064
Quote:
Originally Posted by WolfWhistle View Post
Burning rubber or burning wires? You could get on the roof and take the cover off; have someone inside start the AC and see what you can see. Watch out for the fan... which I have seen an older unit that the fan didn't turn and got hot. I don't think it caused a bad smell, since its on the outside. I would take a quick look, but it sounds to me you need professional help... err... your unit needs professional help. Wolf.
I think you are on it. Turbs, what I think OP meant was if the circulating fan is run without running the cooling function it doesn't smell. (Fan circulating air only) When the compressor is activated (by turning on the cool function) there is a smell. If the fan that pulls air through the condenser outside is frozen it would smell. While it should be a separate system, some of that burning smell could get sucked inside. If that motor was frozen,it would not cool as well but that might not be the first thing that is obvious. Run like that too long and it could burn up what is left of that motor.
__________________
Evereddie is online now   Reply With Quote
Old 07-31-2014, 11:01 PM   #8
Junior Member
 
Join Date: Mar 2014
Posts: 15
Ya I had it all open and ran it. Everything seemed good no smoke everything turned. Nothing out of the ordinary I'm about ready to let her burn.
__________________
cybulskiet is offline   Reply With Quote
Old 07-31-2014, 11:21 PM   #9
Junior Member
 
Join Date: Mar 2014
Posts: 15
Ya I had it all open and ran it. Everything seemed good no smoke everything turned. Nothing out of the ordinary I'm about ready to let her burn.
__________________
cybulskiet is offline   Reply With Quote
Old 08-02-2014, 07:40 AM   #10
Senior Member
 
Join Date: Apr 2012
Posts: 3,155
I love the smell of napalm in the morning!
__________________

__________________
WolfWhistle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:59 AM.