Reply
 
Thread Tools Display Modes
Old 04-07-2014, 10:22 AM   #11
Member
 
dhatfield6's Avatar
 
Join Date: Feb 2013
Location: Louisiana
Posts: 50
Send a message via Skype™ to dhatfield6
I suggest a very thorough PDI of the unit, which I didn't get because I purchased the unit from RV Wholesalers and had it delivered. A BIG learning on my part as this was my first RV.
But to answer your question to the solution, it was still another warranty fix and the service technician only said it was wired incorrectly.
__________________

__________________
Doug & Kim
2013 Forest River Thunderbolt XLR 380 AMP, 2013 Ford SD F-450 DRW 4WD CC 172" King Ranch
2012 H-D FLHTK Electra Glide Ultra Limited, 2004 H-D FXSTDSE2 Screamin Eagle Deuce
[FONT=Arial]Trips in 2013-(4) Nights Camped-(56) Trips in 2014-(5), Nights Camped-(60)
Trips in 2015-(4) Nights Camped-(44) Trips in 2016-(2) Nights Camped-(17)
dhatfield6 is offline   Reply With Quote
Old 05-26-2014, 06:58 PM   #12
Junior Member
 
Join Date: Nov 2012
Posts: 17
Mine still isn't working at this point, but I haven't done a lot of troubleshooting. I checked the frame switch and know how everything is supposed to work, which it did just fine for a while.

Not sure what's next, but may take it to a dealer for warranty work.
__________________

__________________
jwhitemx15 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:07 AM.