Reply
 
Thread Tools Display Modes
Old 07-04-2016, 08:43 AM   #1
Junior Member
 
Join Date: Nov 2014
Posts: 13
Generator problems again

I have a 5500 Onan Cummins in my XLR it has 500 hr. It will not hold a load rpms just go up and down even without a load. I has been serviced according to the manual just had the fuel pump replaced and still the same. Any ideas?
__________________

__________________
rfregia is offline   Reply With Quote
Old 07-04-2016, 02:49 PM   #2
Senior Member
 
R3Jones's Avatar
 
Join Date: Feb 2015
Location: Florida
Posts: 231
Are you getting any error or fault codes? Did you replace fuel filter?




-R.Jones
Nitro 31FQSL
__________________

__________________
R3Jones is offline   Reply With Quote
Old 07-04-2016, 02:51 PM   #3
Junior Member
 
Join Date: Nov 2014
Posts: 13
Quote:
Originally Posted by R3Jones View Post
Are you getting any error or fault codes? Did you replace fuel filter?




-R.Jones
Nitro 31FQSL
Yes sir fuel filter was replaced with pump. Error is 36.
__________________
rfregia is offline   Reply With Quote
Old 07-04-2016, 03:10 PM   #4
Senior Member
 
R3Jones's Avatar
 
Join Date: Feb 2015
Location: Florida
Posts: 231
I've had error code 36 twice. The first time I was low on gas. The second time my fuel filter was clogged.

If you've recently replaced the fuel pump and are sure your full on fuel I'd focus on the fuel lines. The fuel line is usually strapped to the outside of the i beam. It might be pinched. If everything looks good you might want to replace the fuel filter.




-R.Jones
Nitro 31FQSL
__________________
R3Jones is offline   Reply With Quote
Old 07-04-2016, 06:15 PM   #5
Senior Member
 
dwhit's Avatar
 
Join Date: Nov 2015
Location: Chicago, Rochester now GA/SC at Lake Hartwell
Posts: 131
Sounds like my problem which was fuel pump. Was it actually replaced? Hook it up to 12vdc and see if it pumps enough to fill a jar in 15 seconds.

I replaced pump myself...started immediately and ran beautifully. I didn't replace filter.

17 year old 5500 w/700 hours.

Your units' fuel tank at least 1/2 full?
__________________
2014 XLR 415AMP, 2011 F350 Lariat 6.7 DRW, three bikes, NRA Benefactors.
Traveling 7 months/year
dwhit is offline   Reply With Quote
Old 07-04-2016, 06:23 PM   #6
Junior Member
 
Join Date: Jul 2016
Location: Winter Garden Fl
Posts: 6
It also sounds as if the carburetor has gum and garnish, entirely possible at those hours and repair history. Get some good fuel system cleaner and see if that corrects the problem.
__________________
Uberluber is offline   Reply With Quote
Old 07-04-2016, 06:30 PM   #7
Senior Member
 
dwhit's Avatar
 
Join Date: Nov 2015
Location: Chicago, Rochester now GA/SC at Lake Hartwell
Posts: 131
I ran a 50% solution of Sea Foam thru mine...helped a little...smoked a lot.
__________________
2014 XLR 415AMP, 2011 F350 Lariat 6.7 DRW, three bikes, NRA Benefactors.
Traveling 7 months/year
dwhit is offline   Reply With Quote
Old 07-04-2016, 08:59 PM   #8
Member
 
Mainous's Avatar
 
Join Date: Apr 2015
Posts: 40
Do you hear a ticking sound when this happens? This would be the fuel pump cavitating and running dry. On my 31fqsl, I've found that the Onan pump on its own is not getting the job done. Primarily because of the long run of rubber hose to the tank at the other end of the RV. I intend to install a small lift pump to keep the line pressurized and assist the on board pump.

Jeff
__________________
Thanks,

Jeff

-2016 XLR Nitro 31 FQSL
-2006 Chev Silverado 2500HD Duramax LBZ
Mainous is offline   Reply With Quote
Old 07-04-2016, 09:29 PM   #9
Senior Member
 
Join Date: Jul 2014
Posts: 165
Code 36. Generator stopped without a command from the switch.
Usually related to fuel or the lack there of.
Also spark plugs, clogged air filter, clogged fuel filter, bad fuel pump. depends on the age, but at one time there was a fuel filter on the carburetor and one on the pump. The one on the carb was been eliminated.
A dirty/gummed up carburetor is also a cause. They are not rebuildable; must replace with new.
There is s YouTube video showing how to try and clean it with SeaFoam.
__________________
BBQGUY is offline   Reply With Quote
Old 07-09-2016, 10:04 AM   #10
Junior Member
 
Join Date: Nov 2014
Posts: 13
Thanks everyone. A little up date new fuel pump and filter a full service including spark plugs. Same result now it's giving a code 15. I have it scheduled for the shop me t week I will update once it is fixed.
__________________

__________________
Tow rig: 2014 Ram 3500 CC
Old TH: 2007 376srv wildwood sport
New TH: 2014 340X12HP
rfregia is offline   Reply With Quote
Reply

Tags
generator

« 29 HFS | Table »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:33 AM.