Thread Tools Display Modes
Old 02-08-2016, 08:20 PM   #11
Phat Phrog Stunt Team
TURBS's Avatar
Join Date: Aug 2011
Location: Iowa
Posts: 34,205
Glad to hear it was 120v!
Now did the microwave short out causing the burnt wires or was it a bad connection that burnt the wires?

2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"

TURBS is offline   Reply With Quote
Old 02-08-2016, 09:05 PM   #12
Senior Member
Join Date: Feb 2015
Location: North Ga.
Posts: 170
WE checked the line build sheet as beachcamper asked in his reply and the model # was listed BUT the serial # was never listed by FR. As per burnt wires, their is no way to tell. The inside of the microwave was all shot. Things shorted, burnt and blown.
Who knows! The the cord or plug showed no signs of arcing or burnt.

hdmtnrider is offline   Reply With Quote
Old 02-09-2016, 06:50 AM   #13
Junior Member
Join Date: Jan 2015
Posts: 2
Did he use the appliance last year? If he has never used it or set the clock ask for the hi pot test from the factory. I had a radio with similar problems.
dberg is online now   Reply With Quote
Old 02-13-2016, 09:02 PM   #14
Senior Member
Taranwanderer's Avatar
Join Date: Oct 2011
Location: NEPA
Posts: 1,368
Not that this is your problem, since you verified the 120 vs 240 question, but the easiest way to see if your converter is working is to take a voltmeter reading off your battery with the shore power disconnected, it'll read around 12.6v or so, depending on the battery's condition. Then hook up the shore power and test it again, it should read 13.3v or even higher (14+) if your converter is in "bulk" mode.

Good luck!
2015 XLR Hyperlite 30HFS5 (mods being performed regularly)
2009 Salem LA 292fkds (gone)
Nights- ('12)23 ('13)23 ('14)15 ('15)31 ('16)25
2014 Harley Davidson FLHX (XLR cargo)
2014 VW Jetta TDI (diesel sipper, camping support vehicle)
2011 Ram 2500 CC 4X4 CTD, B&W Companion (toy hauler hauler)
Taranwanderer is offline   Reply With Quote
Old 02-13-2016, 09:49 PM   #15
Senior Member
SeaDog's Avatar
Join Date: Jan 2016
Location: Idaho
Posts: 1,596
My TT came with a magic chef residential unit and when I went to heat a bowl of soup it started vibrating and making all kinds of noise and smelled of burning insulation. these units are not high end microwaves. I marked the case so I won't get the same unit back. Mine had no serial number just model number

Retired Navy
Jake my sidekick (yellow Lab)
2006 F350 6.0
2016 Flagstaff 26 FKWS
AF&AM of Idaho
SeaDog is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:27 AM.