Thread Tools Display Modes
Old 04-18-2013, 09:12 PM   #1
Junior Member
Rdnkcanadian's Avatar
Join Date: Apr 2013
Posts: 3
Heated tanks issues

I have a 2011 32'shockwave fifth wheel with 12v heat strips in the tanks. Any time I am plugged into shore power or have the generator running the 12v 15a fuse for the strips blows. It works fine on batterie power but is hard on consumption. Any one else have similar problems?
Rdnkcanadian is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:10 PM.