Reply
 
Thread Tools Display Modes
Old 04-14-2015, 03:15 PM   #11
Senior Member
 
Join Date: Dec 2014
Location: oakdale, ca
Posts: 289
The transfer switch is usually in the cargo area between the geni and the main fuse panel. you could check to see if a wire came loose inside.
__________________

__________________
j free is offline   Reply With Quote
Old 04-14-2015, 03:41 PM   #12
Senior Member
 
Rookie19's Avatar
 
Join Date: Sep 2014
Posts: 97
One other thing I just thought of... Did you check the breaker on the generator itself?
__________________

__________________
Tow rig - 2006 F350 with some goodies
Trailer - 2014 T27FQDX
Toys - 2005 yfz450 with some goodies, 2005 rhino 660
Rookie19 is offline   Reply With Quote
Old 04-14-2015, 03:48 PM   #13
Junior Member
 
Join Date: Apr 2015
Posts: 8
Yep...Checked all fuses from the gen to the panel.
__________________
NVSmithers is offline   Reply With Quote
Old 04-14-2015, 05:03 PM   #14
Senior Member
 
Rookie19's Avatar
 
Join Date: Sep 2014
Posts: 97
Just thought I would confirm. Don't want to look over the little things.
__________________
Tow rig - 2006 F350 with some goodies
Trailer - 2014 T27FQDX
Toys - 2005 yfz450 with some goodies, 2005 rhino 660
Rookie19 is offline   Reply With Quote
Old 04-14-2015, 05:34 PM   #15
Junior Member
 
Join Date: Apr 2015
Posts: 8
Quote:
Originally Posted by Rookie19 View Post
Just thought I would confirm. Don't want to look over the little things.
Indeed.....It happens!
__________________
NVSmithers is offline   Reply With Quote
Old 04-18-2015, 04:26 PM   #16
Junior Member
 
Join Date: Apr 2015
Posts: 8
In case anyone was wondering I tore power center all apart and found out it was indeed the Power Transfer Relay. The relay itself was sticking and not working. So I messed around with it for a bit, got it loosened up and now it works like a charm.
Attached Thumbnails
Click image for larger version

Name:	20150418_124534[1].jpg
Views:	143
Size:	317.3 KB
ID:	74613   Click image for larger version

Name:	20150418_114557[1].jpg
Views:	139
Size:	257.2 KB
ID:	74614  
__________________
NVSmithers is offline   Reply With Quote
Old 04-27-2015, 12:44 AM   #17
Junior Member
 
WR450rider's Avatar
 
Join Date: Aug 2012
Posts: 28
Well done Smithers!!
With the dealer service department out months on their schedule, I'm just learning to fix everything myself as well!

The service schedule just shows you how hastily these things are slapped together!


Sent from my iPhone using Forest River Forums
__________________

__________________
WR450rider is offline   Reply With Quote
Reply

Tags
generator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:38 AM.