Thread Tools Display Modes
Old 06-04-2014, 04:10 AM   #1
Junior Member
Join Date: Apr 2014
Posts: 12
Solar Panels

Has any body with solar panels had any trouble with one of their batteries over heating and really stinking things up? Over charging or bad battery. This is a new stealth 2313, three months old.

MBart is offline   Reply With Quote
Old 06-04-2014, 04:23 AM   #2
Join Date: Aug 2013
Location: Corner Brook, Newfoundland
Posts: 57
Do you have a charge controller between the panel & batteries? This will prevent overcharging. I have a 123 watt Sharp panel, 20 amp controller & 2 - 6 volt batteries. Fabulous results. Rarely start the generator.

Obrieri is offline   Reply With Quote
Old 06-04-2014, 04:51 AM   #3
Senior Member
RPAspey's Avatar
Join Date: Jul 2008
Location: central PA
Posts: 972
How about some details on your set up? What are the battery voltages on charge and at rest? Is the converter on? Definitely sounds like over charging so be VERY careful around the batteries. I think I would make sure the converter is turned off, and disconnect the solar until you check out the batteries. Overcharged batteries can and do explode. After the batteries are disconnected from the system, check the fluid in them. It's likely that its low. If so, add only distilled water, but don't overfill.

Lots of help here, we just need some information.
2000 Cherokee 29BH with 6V batteries, LED lights & 400 watts of solar power, flipped axles and raised. 2007 Tundra 5.7L DC-LB with lots of mods. C-co, 8/158th AVN Maint.
RPAspey is offline   Reply With Quote
Old 06-05-2014, 01:02 PM   #4
Senior Member
Jjs2000z's Avatar
Join Date: Jul 2013
Location: Southern California
Posts: 231
Also maybe you need to program the controller to your specific battery. More details are needed.

I have solar on my 2014 stealth 2715 with 2- 6 volts batteries and this set up works wonders.
2014 stealth 2714
Jjs2000z is offline   Reply With Quote
Old 06-06-2014, 02:29 AM   #5
Junior Member
Join Date: Apr 2014
Posts: 12
Thanks for the info guys. It ended up my batteries were low on water and I think my controller was froze. After I unhooked the the batteries and reattached them I started getting all the numbers that I was supposed to get. It was also set up for a AGM battery, I have flooded batteries. Seems to be charging fine now.
MBart is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:43 AM.