Thread Tools Display Modes
Old 04-06-2016, 12:48 PM   #1
Junior Member
Join Date: Mar 2016
Posts: 19
2016 Lacrosse324

Backward vents causing water to get on motherboard . you can see wires inside vent. Allowing water to get on wires taking it to motherboard. Dust pan works for now
Attached Thumbnails
Click image for larger version

Name:	1459964704471.jpg
Views:	62
Size:	53.9 KB
ID:	104086   Click image for larger version

Name:	1459964863801.jpg
Views:	59
Size:	38.3 KB
ID:	104087  

Lookng4us is offline   Reply With Quote
Old 04-06-2016, 06:18 PM   #2
Join Date: Sep 2013
Posts: 58
I had the same problem. That design is correct per Atwood. It's designed that way to keep exhaust fumes from entering the fresh air intake of the blower. Check the silicone around the black insert where it meets the trailer wall. Mine was not sealed well from the factory. Also, make sure the screws in the door are snug. There should be a black foam seal on the inside of the door. For added protection, I cut a small (1/4") piece of wood and placed under the board. I then applied a small bead of silicone to the front side of the board where it rested on the wood. Have not had a problem since.

Very poor design on the door. Hope this helps.

Sent from my iPhone using Forest River Forums

2914 Tracer 2950BHS
Griswalds is offline   Reply With Quote
Old 04-06-2016, 10:37 PM   #3
Junior Member
Join Date: Mar 2016
Posts: 19
Thanks very much I'll try your advice thanks so much again
Lookng4us is offline   Reply With Quote
Old 04-07-2016, 05:54 AM   #4
Site Team
Platokidd's Avatar
Join Date: Aug 2012
Location: Home of the National League Central Champs
Posts: 5,503
Looks like they change the cover since 2014. Im going to pull mine off today to check things out.
Might want to put some screen covers on to keep the bugs out.

Click image for larger version

Name:	IMG_20140413_103314_596.jpg
Views:	70
Size:	232.2 KB
ID:	104137
Next year is here - GO CUBS- 4 more WINS to go
2014 LaCrosse 323RST-TE-C
2009 CHEVY 2500HD Silverado Z71
2016- 89 nights of camping
Platokidd is offline   Reply With Quote
Old 05-24-2016, 10:27 PM   #5
Junior Member
Join Date: Dec 2015
Posts: 1
I had the same problem. Called Prime Time and they said they were aware of the problem and had a fix for it. I took my trailer in to the dealership and they installed a new cover.
KrisKatz is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:57 AM.