Reply
 
Thread Tools Display Modes
Old 11-29-2012, 12:12 PM   #21
Senior Member
 
Join Date: Nov 2010
Posts: 116
Quote:
Originally Posted by paulahov View Post
I was able to do that on previous campers but this one has an odd thermostat. You press once for hi/lo fan, twice for a/c and then a third time for furnace. It has a light that shows up to let you know what setting you are using. Then another button is used for the temperature setting. Maybe we are doing something wrong and I'll double check with the dealer. But this weekend when I pressed the button for furnace the fan never shut off. I didn't mind it while the heater was running but when it kicks off and the fan still runs it get a bit cold.
Check the manual...

When setting the digital thermostat, start with the fan setting. While using the AC the Auto setting will allow the fan to cycle on/off with the compressor.
In the High or Low setting the fan will run constantly whether the thermostat is set on AC or Furnace, so be sure to set the fan on the Auto setting when using the Furnace.
If you experience condensation while using the Furnace, you can set the fan to the High or Low setting to help with air movement in the trailer.

Use the On/Off button to cycle between Fan/Cool/Furnace. Use the +/- to cycle the Fan between Auto/High/Low and of course to set the temp when using the AC or furnance.

Also note that while using the AC with the fan in Auto mode, if the room temp is 5 or more warmer than the set temp on the termostat the fan will run on high. Once the difference is 4 or less the fan will run on low.
So if you just set up camp and the difference is 5 or more the fan will run on high and once the tt cools off to a difference of 4 or less the fan will stop momentarily, then kick back on running in the low mode.
__________________

__________________
2011 Primetime LaCrosse 318BHS Touring Ed
Joined the PT family on 10/2010
2006 Chevrolet 2500HD 4x4 T/V

John
foxhead is offline   Reply With Quote
Old 11-29-2012, 12:20 PM   #22
WJC
Member
 
Join Date: Sep 2010
Location: NJ
Posts: 79
I guess i'm the other one guy, since I bought the trailer I had nothing but problems! While under warranty Primetime did try to fix the problems but could not, first year we had the trailer back to the dealer more than we went camping!
1Tires making contact with trailer floor wheel wells,PT replaced equalizers did not help, springs were replaced still makes contact and now have nice grooves in wheel wells! From this I have tire wear problem, two of the four tires are severely worn out on edges, I told them this was possibly do to the work on the axles, I was told its out of warranty, and the cost to realign $1000.00
2 Slides leaked, after replacing seals twice the leaks did stop!
3 Wiper seals were coming off and still come off when opening and closing! They later changed the design mine are just glued in place with no trim or molding, newer models have molding to hold in place!
4 Trailer had excessive caulk or butyl rubber coming out at corners, PT told me this is normal but I could trim it back if I didn't like the way it looked!, I did and found a gap between front and side walls now delaminating! When I found this problem I contacted PT which said the trailer is out of warranty and was told they would do nothing about it! I tried to explain the reason this should be covered is that it came from the factory this way! And the cost from dealer to have it fixed was 1700.00!! These are not nit picking problems! I also had the little ones like black and gray handles came off, shelves coming down, black floor vapor barrier ripping under slides!
What is frustrating is hearing how great PT is in fixing the trailer problems and being the one that has not had one problem fixed and when I talked to PT all I got is it's out of there hands!
Attached Thumbnails
Click image for larger version

Name:	003.jpg
Views:	108
Size:	39.7 KB
ID:	21931   Click image for larger version

Name:	004.jpg
Views:	103
Size:	41.3 KB
ID:	21932   Click image for larger version

Name:	001.jpg
Views:	87
Size:	29.8 KB
ID:	21936   Click image for larger version

Name:	002.jpg
Views:	93
Size:	32.3 KB
ID:	21938  
__________________

__________________
WJC
Dodge Durango 5.7 Hemi
2010 Primetime Tracer 3000 BHS Lemon
WJC is offline   Reply With Quote
Old 12-01-2012, 08:53 PM   #23
Junior Member
 
Join Date: Nov 2012
Posts: 3
I think I understand the thermostat now, thanks! We did hear back from our Primetime rep who told my husband we are screwed and to just deal with our canopy problem. I can't believe the way this was handled. We might be trading in because I don't want a camper that has customer service like that. Our dealer is looking at options to fix at their own cost and in no way should they have to do that. I think I see a Better Business Bureau report being filed in the next few days.

Martin even wanted to email them pics to show that it wasn't just a slight rub and they told him not to bother it is our problem now. WOW! Very sad.
__________________
paulahov is offline   Reply With Quote
Old 12-08-2012, 08:03 PM   #24
on_the_bayou
 
PrimeTime's Avatar
 
Join Date: Nov 2012
Location: Gibson, Louisiana
Posts: 46
Smile

Quote:
Originally Posted by paulahov View Post
I was able to do that on previous campers but this one has an odd thermostat. You press once for hi/lo fan, twice for a/c and then a third time for furnace. It has a light that shows up to let you know what setting you are using. Then another button is used for the temperature setting. Maybe we are doing something wrong and I'll double check with the dealer. But this weekend when I pressed the button for furnace the fan never shut off. I didn't mind it while the heater was running but when it kicks off and the fan still runs it get a bit cold.
I believe I have the same type. Press the On/Off switch once for fan then use the +/- buttons the change Hi Lo Auto
__________________
PrimeTime is offline   Reply With Quote
Old 12-09-2012, 08:18 PM   #25
Senior Member
 
LKicklight's Avatar
 
Join Date: Feb 2012
Location: CHATSWORTH, GA.
Posts: 1,121
Take it back

This sounds all so familiar to me and another 270RET owner of just over a year..
My advice to you, hook the darn thing up and take it back to the factory in Elkhart, IN. My friend did that with his unit, we chose to let the dealer repair everything, big mistake, takes for ever waiting on parts to be shipped to the dealer..also, you will get treated very well by the factory as my friend did...
We both had a list that would choke a mule......
Good Luck and take my advice an return it to the factory as soon as possible..





Quote:
Originally Posted by Austinjenna View Post
Crusader 298 owner here and I have never seen so many problems with a new unit.

1) During PDI while testing out the heater there is no heat coming from register, the dealer checks and the vent is crushed shut.

2). One of the lights does not work after getting home.

3). The light above the dinette has 1 bulb out, no problem..I take it out and see its an 1156 bulb so i put a new one in and nothing..try, wiggle, mess around some more and finally look at the socket. Its an 1157 socket with the wrong bulb in it. The other one was the same way as was the other units at the dealership. (BTW the other dealer units also only had 1 bulb working)

4). Main slide does not come out, maybe 1-2 feet then stops

5). Front landing leg breaks

6). Toilet leaks and needs to be replaced

7). No cable tv. The cable was not even hooked to the panel and was about 6 inches to short to even connect to the panel.

8). Every single sink leaked

9). Main slide does not come out again, same problem as before about 1-2 ft and thats it.

10). Black tank falls out..literally

11). Dump valve breaks

12). Shower will not drain into the tank first time using it

13). That metal peice that hold the spare tire on is bent like a V. Okay i thought it must have been loose and the bouncing around did it, no problem. Straighten it out and put it back on and make sure its tight..same thing happens

Also some other general complaints:
Why is it that I cant have my awning all the way out. If I open it all the way the top of the door will rub on the awning.

Why does the main slide move so ungodly slow? I know they have the new in wall motors but this thing barely moves and seems like it is struggling all the time. Dealer says thats the way it is.

This is not my first fiver and I understand all the stupid things like the tank sensors never working correctly and other piddly stuff, but this is ridiculous. Every time we go camping we come home unload and I need to drive it to the dealer for something that broke. I am sure I also left off a bunch of other things that were wrong too.

The way it is right now I would never recomend a prime time unit to anyone, and when they ask me about it I do tell them.
__________________
LKicklight is offline   Reply With Quote
Old 12-09-2012, 10:41 PM   #26
Senior Member
 
Bill_C's Avatar
 
Join Date: Apr 2011
Posts: 193
Quote:
Originally Posted by ironj View Post
i always cringe when someone comes on here with SERIOUS issues on thier new trailer, because we ALL know its gonna happen...someone, somewhere drops the ball SERIOUSLY.....is it prime to blame? forest river? the dealer who did the make ready? the owner who did the pdi??
well said !
__________________
DRINK COFFEE--do stupid things faster and with more energy ! Rockwood 5th wheel, Signature Untralite, 8244S
Tow Vehicle: Ram 3500 6.4 litre Hemi.
Bill_C is offline   Reply With Quote
Old 12-10-2012, 04:45 AM   #27
Senior Member
 
dretired's Avatar
 
Join Date: Feb 2011
Location: Michigan
Posts: 1,037
Quote:
Originally Posted by paulahov View Post
I was able to do that on previous campers but this one has an odd thermostat. You press once for hi/lo fan, twice for a/c and then a third time for furnace. It has a light that shows up to let you know what setting you are using. Then another button is used for the temperature setting. Maybe we are doing something wrong and I'll double check with the dealer. But this weekend when I pressed the button for furnace the fan never shut off. I didn't mind it while the heater was running but when it kicks off and the fan still runs it get a bit cold.
You want the "other" button to be set at AU..which means auto.. the fan should shut down after the furnace kicks off 1-2 minutes later
__________________
2014 Crusader 325 TE....2012.. F 250.. Supercab XLT, 4x2 , diesel....days camped 2011 ... 28.... days camped 2012...115 ... days camped 2013...155...2014...171 and counting
dretired is offline   Reply With Quote
Old 12-10-2012, 10:32 PM   #28
Anacortesians
 
Join Date: Oct 2010
Location: Anacortes, WA
Posts: 1,167
The problem isn't quality control, it's poor design. If the engineering and design folks put out designs that were "idiot proof", the production "idiots" couldn't screw it up.

Whenever I've done fixes on my '02 GT325 motorhome, I'm gob-smacked by the incredible ineptitude of the people that designed things. Quality can't be retrofitted by QC if the inital design is flawed. It just costs too much to go back and try to rectify crappy design after the device is built.

One of the prime parameters in design when I worked for Boeing was "don't just make it foolproof, make it damned foolproof". There are far too many "chewing gum and baling wire" designers and engineers out there and the RV industry seems to employ a larger perentage of them than other industries.

We're not planning to sell our GT until we're done RVing (maybe in 2014), and I'll live with the problems until we do, but I sure wouldn't recommend anyone else to buy one of the same vintage as our '02. Maybe more recent models are better, but I sure wouldn't hold my breath waiting to hear of any!
__________________
Frank and Eileen
No longer RVers or FR owners
F and E Damp is offline   Reply With Quote
Old 12-11-2012, 09:28 AM   #29
Senior Member
 
LKicklight's Avatar
 
Join Date: Feb 2012
Location: CHATSWORTH, GA.
Posts: 1,121
Design

I must agree with you totally...we also own a 2003 Sunnybrook Travel Trailor, bought new in 03', has been back to the dealership only one time...that was for a new slide out awning...No doubt there are some defacts that have never shown up, but for all these years and many trips, no problems that has ever left us on the side of the road..The new breed of units, whole new game...Our Crusader 270RET...you are right on...Always said, being an Architectural Engineer, I would love to design my own RV....having built airplanes at one time in my life and owned five RV units, think I could do a pretty good job....especially on the slide outs..
Regards,
__________________
LKicklight is offline   Reply With Quote
Old 12-25-2012, 10:04 PM   #30
Senior Member
 
Join Date: Nov 2011
Location: Brewerton, NY
Posts: 329
Well I had frame damage on mime. They took it back to the factory and fixed everything and then some. They really did go above and beyond. Rv guy gave me updates weekly.

All I can add is I have owned Jayco, cougar, and a Montana , and they all had there problems , problems that you though wold be picked up at the factory. He'll my cougar had trim on the floor all over the place and more falling off when I picked it up...and keystone is 1 in sales in the us...and they have there issues trust me. I was on the Montana owner group forum back then, and many people praised how good they were, but you still had the guy in there that had nothing but problems...
Hang in there, contact them directly, I am sure they will do the best they can to make it right.
__________________

__________________

2015 Dodge 2500 Big Horn 4x4 6.4 HEMI
2015 Grand Designs Reflections 323 BHS
Reese 16K Quick Slide with Factory Rail Kit Option
kozzy is offline   Reply With Quote
Reply

Tags
prime time

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:54 PM.