Reply
 
Thread Tools Display Modes
Old 08-06-2017, 10:15 AM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 4
Furnace not working

Hello everyone,

Just recently bought a Crusader lite 34 MB and when I did the PDI we didn't check the furnace probably cause it was near 100 degrees that day. Well now I've taken the 5th wheel out a couple of times and it got chilly at night in the high country of Colorado. And when I set the thermostat to activate the heater I get some clicking in the ac unit but that's all. I have noticed a burnt fuse in fuse box but when I put new one in it just powers the CO2 sensor. Anyone have any similar experiences?

Thanks,
__________________

Jtoyo007 is offline   Reply With Quote
Old 08-06-2017, 06:53 PM   #2
Senior Member
 
GeoArm's Avatar
 
Join Date: Feb 2013
Posts: 103
Stupid question, gas turned on. On my crusader there is a switch on the furnace ( had to take the wooden grill off to access) seem when I had it opened I decided to vacuum the area , must have hit the switch, as the same happened to me, got cold, but furnace would come on till I opened it up again and flipped the switch.
__________________

__________________

2012 Ram 2500 Hemi
2013 PT Crusader 295RST TE
GeoArm is offline   Reply With Quote
Old 08-07-2017, 12:13 PM   #3
Senior Member
 
Join Date: Jun 2013
Location: Katy, Tx
Posts: 190
Quote:
Originally Posted by Jtoyo007 View Post
Hello everyone,

Just recently bought a Crusader lite 34 MB and when I did the PDI we didn't check the furnace probably cause it was near 100 degrees that day. Well now I've taken the 5th wheel out a couple of times and it got chilly at night in the high country of Colorado. And when I set the thermostat to activate the heater I get some clicking in the ac unit but that's all. I have noticed a burnt fuse in fuse box but when I put new one in it just powers the CO2 sensor. Anyone have any similar experiences?

Thanks,
Unless something has changed, the heater should be on Zone 1 if you have multiple zones.
__________________
2015 Crusader 315rst
2016 Ford F350 SRW 4x4 King Ranch 6.7L
Houstonkid is offline   Reply With Quote
Old 08-07-2017, 01:59 PM   #4
Junior Member
 
Join Date: Aug 2017
Posts: 4
Thanks for the responses
1. I did turn on and off and back on the furnace switch and gas was on
2. I only have one zone on my thermostat
Jtoyo007 is offline   Reply With Quote
Old 10-26-2017, 04:09 PM   #5
Junior Member
 
nsoleo113's Avatar
 
Join Date: Apr 2017
Posts: 16
Furnace not working

I just bought a Tracer in April and had never needed the heater until last week. Turns out the port was corroded and had to be cleaned. They think it was from condensation when it was in storage before being brought to the dealer last spring. That tells me they probably never tested it before we bought it. Since weather was warm and all.
nsoleo113 is offline   Reply With Quote
Old 11-14-2017, 06:10 PM   #6
Junior Member
 
Join Date: Jun 2015
Posts: 4
I am dealing with the same issue with my 2016 Lacrosse 318BHS, the control board is showing a lockout fault and I think I traced it back to a bad igniter/flame sensor - fingers crossed
fireman2213 is offline   Reply With Quote
Old 11-14-2017, 10:08 PM   #7
Junior Member
 
nsoleo113's Avatar
 
Join Date: Apr 2017
Posts: 16
Turns out the port on our furnace was corroded. Dealer cleaned it out and working great now. Mustíve been from when it was just sitting around the dealers storage area during the late winter months.
nsoleo113 is offline   Reply With Quote
Old 11-14-2017, 10:16 PM   #8
Site Team
 
Platokidd's Avatar
 
Join Date: Aug 2012
Location: top side land of Lincoln
Posts: 7,247
This fall while camping in cold weather we ran the furnace all day. Left camp and went out for a few hours. It was in the 30's when we got back to camp and none of the propane items worked.

Good thing we had the fireplace.
Next day in the morning the hwh and furnace came on.
My thinking here is after using the propane, shutting things off and after we left the propane line or regulator froze up. Next day it thawed out and worked.
__________________

__________________
2014 LaCrosse 323RST-TE-C
2009 Chevy 2500HD Z71
Seasonal

R.I.P. Luke the campin dog
Platokidd is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:39 PM.


×