Reply
 
Thread Tools Display Modes
Old 05-27-2013, 05:18 PM   #1
Junior Member
 
Join Date: May 2013
Posts: 11
New 2013 Avenger 26BH TED - Poor QA?

We just finished our first campout with the new 2013 Avenger 26BH Touring and we had a great time. However, we had some problems that got me worried about the quality / quality assurance of the Prime Time. Has anybody else had issues like this with Prime Time? Should I be worried?

Issues so far.

- Gray water level indicator does not work. (Warranty work)
- TV power supply no longer works (replaced with Radio Shack power supply and called Legend for a replacement)
- DVD did not play on TV. Took DVD off the wall and found that the DVD video cable was plugged into the video IN instead of OUT.
- The door is really difficult to open / close. The handle seems to stick when closed and you really have to slam it hard to make it close. (Warranty work)
- The Velcro on the back of the dining room bench seat cushions came off the wood. Not a big deal, but adds to the poor quality worry.
- (edit) Missing screws on a few blind holding tabs.

Not really a manufacturing issue, but not sure how to fix. Any thoughts?
- The tub does not have any lip on the non-wall side so water just runs over the edge on onto the floor. I was thinking some weather stripping here may work on redirecting the water or I could always ensure I level to one side.

Thanks,

FlyDye
__________________

flydye is offline   Reply With Quote
Old 05-27-2013, 05:31 PM   #2
Senior Member
 
kho6658's Avatar
 
Join Date: Nov 2012
Location: Austin, TX
Posts: 288
My kids have a hard time opening and closing the door, but really not a problem for me or DW. Yes I have noticed that the Velcro was coming off but easy fix from home depot with better quality velcro. I'm still very happy with the quality of it. It took me 9 months of looking at others and very happy with my decision.
__________________

__________________
2019 Sabre 36BHQ
2017 F350 Lariat

My first
kho6658 is offline   Reply With Quote
Old 05-27-2013, 06:33 PM   #3
Junior Member
 
Join Date: May 2013
Posts: 11
Quote:
Originally Posted by kho6658 View Post
My kids have a hard time opening and closing the door, but really not a problem for me or DW. Yes I have noticed that the Velcro was coming off but easy fix from home depot with better quality velcro. I'm still very happy with the quality of it. It took me 9 months of looking at others and very happy with my decision.
Thank you for the info. We also looked around for a long time before we found the Avenger. We really do like it, but we ran into these problems. The more time it spends at the shop, the less time my family can use it for camping! Hopefully after I get these items fixed we will be problem free.
flydye is offline   Reply With Quote
Old 05-28-2013, 03:44 PM   #4
Senior Member
 
kho6658's Avatar
 
Join Date: Nov 2012
Location: Austin, TX
Posts: 288
Quote:
Originally Posted by flydye View Post
Thank you for the info. We also looked around for a long time before we found the Avenger. We really do like it, but we ran into these problems. The more time it spends at the shop, the less time my family can use it for camping! Hopefully after I get these items fixed we will be problem free.
I'm with you on loseing time camping when its in the shop. Unless its something that I can't fix myself, I won't take in for warranty because of the time that it takes for me to get it back to the dealer. My dealer is about an hour from my house and the time it would take me to get it out of storage to the dealer is a pain. I have been lucky that I have only had to make one trip back to the dealer.
__________________
2019 Sabre 36BHQ
2017 F350 Lariat

My first
kho6658 is offline   Reply With Quote
Old 05-28-2013, 09:10 PM   #5
Senior Member
 
Join Date: Nov 2011
Location: Brewerton, NY
Posts: 329
I had a similar issue with my bathtub in my lacrosse, got a drip guard from Home Depot, applied with some caulk, problem solved.


As far as the other issues , I think you will find little issues with any new camper, I know I did, but Prime Time went above and beyond to correct the issues and I have been extremely happy with the level of service I have received.
__________________

2015 Dodge 2500 Big Horn 4x4 6.4 HEMI
2015 Grand Designs Reflections 323 BHS
Reese 16K Quick Slide with Factory Rail Kit Option
kozzy is offline   Reply With Quote
Old 06-26-2013, 08:07 PM   #6
Junior Member
 
Join Date: May 2013
Posts: 11
Update-

Got the trailer back from the dealer and they had to take the black cover/corrugated plastic off the bottom of the trailer to fix the gray water tank. They also said they found some water damage (I only use the tub once to give my son a bath) due to some sealant missing from the factory. Unfortunately, the dealership did a horrible job putting the bottom back on… (Missing foam, wires hanging around, sagging cover, etc.).

I didn’t accept it from the dealership the first time around and they patched it up better, but it’s still not right.

I have a call into Primetime (left a voicemail) to discuss what my options are, if I have any..


Kozzy - Thanks! I'll give that a try. sounds exactly what I'm looking for.
flydye is offline   Reply With Quote
Old 06-27-2013, 02:31 PM   #7
Junior Member
 
Join Date: May 2013
Posts: 11
Update

Update-

Talked with Roger from Prime Time. What an awesome guy! He made some recommendations that Iím going to try which involve following a nice escalation process. Basically try talking with the service manager, if that doesnít work Roger will try to talk with the server manager and if all else fails I can bring the trailer to Prime Time's service center located in Elkhart, IN (Only 3 Ĺ hours away) and they'll make it right.

It is nice to know that Prime Time looks out for their customers.
flydye is offline   Reply With Quote
Old 07-04-2013, 02:55 PM   #8
Senior Member
 
kho6658's Avatar
 
Join Date: Nov 2012
Location: Austin, TX
Posts: 288
I'm having an issue with my shower. Now on two trips when someone takes a shower, the water that hits the front shower wall runs down the wall to the base on the tub and onto the floor. I'm currently camping and this morning I had to raise the right side of the camper to make sure the water doesn't drip out onto the floor. Anyone had this issue?
__________________
2019 Sabre 36BHQ
2017 F350 Lariat

My first
kho6658 is offline   Reply With Quote
Old 07-07-2013, 06:02 PM   #9
Junior Member
 
Join Date: May 2013
Posts: 11
Quote:
Originally Posted by kho6658 View Post
I'm having an issue with my shower. Now on two trips when someone takes a shower, the water that hits the front shower wall runs down the wall to the base on the tub and onto the floor. I'm currently camping and this morning I had to raise the right side of the camper to make sure the water doesn't drip out onto the floor. Anyone had this issue?
Yes. Myself and Kozzy (in his lacrosse) has had this problem. I have not had a chance to try it yet, but Kozzy purchased a drip guard from Home Depot, applied with some caulk, and it solved his problem.
flydye is offline   Reply With Quote
Old 07-08-2013, 05:52 PM   #10
Senior Member
 
kho6658's Avatar
 
Join Date: Nov 2012
Location: Austin, TX
Posts: 288
Thanks I'll give it try. We have another trip planned in a week.
__________________
2019 Sabre 36BHQ
2017 F350 Lariat

My first
kho6658 is offline   Reply With Quote
Old 07-28-2013, 01:50 PM   #11
Junior Member
 
Join Date: Apr 2013
Posts: 14
We just took a two week trip in our 2013 Avenger 26BH... love it, but we too have some small annoying issues. Both our gray water and black water tanks say they are full, even though we know they are empty. One of our interior electrical outlets is coming out of the wall, and our dinette seat is coming apart where it should be stapled. Most importantly, for some reason, our cable does not seem to work when we hook to a cable outlet at a campground. After hooking up the cable, we have ran the auto scan on both cable & air and get nothing... any ideas? I have read the directions and it appears as if we have done everything correctly.
just4fun is offline   Reply With Quote
Old 07-30-2013, 07:40 PM   #12
Junior Member
 
Join Date: May 2013
Posts: 11
Quote:
Originally Posted by just4fun View Post
We just took a two week trip in our 2013 Avenger 26BH... love it, but we too have some small annoying issues. Both our gray water and black water tanks say they are full, even though we know they are empty. One of our interior electrical outlets is coming out of the wall, and our dinette seat is coming apart where it should be stapled. Most importantly, for some reason, our cable does not seem to work when we hook to a cable outlet at a campground. After hooking up the cable, we have ran the auto scan on both cable & air and get nothing... any ideas? I have read the directions and it appears as if we have done everything correctly.
Sorry, other than making sure the TV settings are on antenna or cable based on what you are trying to do, I donít know why it wouldnít work. The power supply for our TV died on the first trip and I called the number that was on the power supply. They were really nice and mailed me a new power supply on their dime.

If you canít get it working I recommend giving the manufacture a call; they were very helpful when I called them.
flydye is offline   Reply With Quote
Old 07-30-2013, 08:26 PM   #13
Junior Member
 
Join Date: Apr 2013
Posts: 14
Thanks - I decided to schedule it for service on all my "issues" in a couple of weeks... hopefully they can figure it out!
just4fun is offline   Reply With Quote
Old 07-31-2013, 07:36 AM   #14
Junior Member
 
Join Date: May 2013
Posts: 11
Quote:
Originally Posted by just4fun View Post
Thanks - I decided to schedule it for service on all my "issues" in a couple of weeks... hopefully they can figure it out!
I hope your issues get resolved better than mine did! The dealership made it worse .. Still trying to get it resolved.. I recommend taking pictures of the problems, and anything you think they need to take apart in order to fix the issues, before bringing it in. I'm not saying you will have the same experience that I did, but I wish I had taken pictures prior to bringing it in for service.
flydye is offline   Reply With Quote
Old 07-31-2013, 01:08 PM   #15
New to Forest River
 
Join Date: Feb 2013
Location: Kansas City, MO
Posts: 109
Quote:
Originally Posted by just4fun View Post
We just took a two week trip in our 2013 Avenger 26BH... love it, but we too have some small annoying issues. Both our gray water and black water tanks say they are full, even though we know they are empty. One of our interior electrical outlets is coming out of the wall, and our dinette seat is coming apart where it should be stapled. Most importantly, for some reason, our cable does not seem to work when we hook to a cable outlet at a campground. After hooking up the cable, we have ran the auto scan on both cable & air and get nothing... any ideas? I have read the directions and it appears as if we have done everything correctly.
Make sure the power booster on your coax connection is turned OFF for cable.
__________________
Mike & Tracy Boyd
2013 LaCrosse 318BHS Touring Edition - Forest River - Prime Time
2006 Silverado 2500HD 4x4 Crewcab SB DMax/Allison
Graduated from 1999 Dodge Ram Extended 2wd 5.9L &
2005 Prowler Lynx Ultralite 29BHS
Mikedboyd is offline   Reply With Quote
Old 07-31-2013, 01:25 PM   #16
Senior Member
 
mjones12's Avatar
 
Join Date: Sep 2009
Location: Lexington, NC
Posts: 2,396
Quote:
Originally Posted by just4fun View Post
We just took a two week trip in our 2013 Avenger 26BH... love it, but we too have some small annoying issues. Both our gray water and black water tanks say they are full, even though we know they are empty. One of our interior electrical outlets is coming out of the wall, and our dinette seat is coming apart where it should be stapled. Most importantly, for some reason, our cable does not seem to work when we hook to a cable outlet at a campground. After hooking up the cable, we have ran the auto scan on both cable & air and get nothing... any ideas? I have read the directions and it appears as if we have done everything correctly.
We had a similar problem with cable on our first trip. To check it, we ran our cable directly from the pedestal, in through the camper door and hooked directly to the TV. Perfect cable service. So we knew the problem was somewhere between the hookup on the outside of the trailer and the place where it comes out near the TV. Took it in and they had to replace a "cable board."
We had to borrow a piece of extra-long cable from the campground to run that test because our regular cable was not long enough. Might be worth a try to eliminate some of the other possibilities.
__________________
2018 Coachmen Apex 249 RBS
2010 Silverado LT 5.3 V8


The world is a great book, of which those who never stir from home
read only a page. - St. Augustine
mjones12 is online now   Reply With Quote
Old 08-03-2013, 05:51 PM   #17
Junior Member
 
Join Date: May 2013
Posts: 11
Update

Finally was able to schedule a meeting time with the service manager Mike. He was very polite; took the time to look at my problems (even crawling on the ground in his business casuals). He apologized for the problems I was experiencing and said that he will get them resolved.

So, the trailer is back at the dealership; hopefully third time's the charm.
flydye is offline   Reply With Quote
Old 08-12-2013, 09:09 PM   #18
Member
 
chris1911's Avatar
 
Join Date: May 2013
Location: GA
Posts: 45
Quote:
Originally Posted by Mikedboyd View Post
Make sure the power booster on your coax connection is turned OFF for cable.
Yep. On the left side of your tv, where the cable goes into the wall, there is a small green light and button. Push that little button and it should work.
chris1911 is offline   Reply With Quote
Old 08-14-2013, 06:40 AM   #19
Site Team
 
Platokidd's Avatar
 
Join Date: Aug 2012
Location: top side land of Lincoln
Posts: 7,255
Quote:
Originally Posted by flydye View Post
Finally was able to schedule a meeting time with the service manager Mike. He was very polite; took the time to look at my problems (even crawling on the ground in his business casuals). He apologized for the problems I was experiencing and said that he will get them resolved.

So, the trailer is back at the dealership; hopefully third time's the charm.
Only 3 times ... hope they get it right..good luck
__________________
2014 LaCrosse 323RST-TE-C
2009 Chevy 2500HD Z71
Seasonal

R.I.P. Luke the campin dog
Platokidd is offline   Reply With Quote
Old 08-14-2013, 07:45 PM   #20
Junior Member
 
Join Date: May 2013
Posts: 11
Update

Picked up the trailer today.

The dealership ended up taking the corrugated plastic underbelly off again and mounting some cross members under the trailer. They then mounted the underbelly to the cross members. They did this only over the axle. Itís still saggy everywhere else, but at least the underbelly isnít touching the axle anymore

I need to add some more expanding foam to a few places where they didnít put enough, but over all I guess itís as good as itís going to get.

Camping time!
__________________

flydye is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:45 AM.


×