Thread Tools Display Modes
Old 11-23-2011, 11:55 PM   #1
Junior Member
Join Date: Sep 2011
Posts: 8
New 308RES

I just purchased a new 308res and
Love the trailer. However, I have some issues.....

1. The GFI in the bathroom will
Not reset. I reset the breakers, turn the power off, no luck!

2. When I brought the trailer home plugged the cord to my 30 amp plug, turn the breaker on, the wife screams smoke! There was
Smoke coming from the breaker box and the TV in the bed room. I turned the
Power off, unplugged the TV and check the panel
Box. No breakers were tripped and no fuses were blown either. The TV works , I removed the tv from the bedroom and plugged it in the house, tv is good. however. My battery will not charge, GFI will not reset, HELP!!!

Ravens is offline   Reply With Quote
Old 11-24-2011, 04:25 AM   #2
Senior Member
cardinal4fun's Avatar
Join Date: Sep 2008
Location: Eastern Iowa
Posts: 314
If you plugged trailer cord into your 30amp dryer connection in your house you pretty much fryed the trailer stuff. If its a 110v 30amp plug different issue.

The gfi plugs that come with unit are very cheep. Good to your local hardware store and get a new gfi plug. Gfi outlets could and for the most part are tied into other outlets, maybe your bathroom gfi is tied to the outlet for the tv.

You will have to take the face plate off the breaker pannel box and see what type of damage was done. The problem could be loose wires,( mfgs are good for not tightening the wires down) check with screw driver for tightness. Maybe there was a bare wire touched something else.

3500 Ram 5.9l diesel
08 35 RLT Cardinal
5th Airborne Pin Box
cardinal4fun is offline   Reply With Quote
Old 11-24-2011, 07:25 AM   #3
Junior Member
Join Date: Sep 2011
Posts: 8
I did not plug the trailer in the dryer of the house. I have a 30 amp connection sideof the house that I use for my TT. I have no red lights in the panel box, all the breakers look good, fuses are good. The receptacles in the kitchen does not work and the microwave has no power. Everything else seems robe working when have a battery charger connected to the battery. When I remove the battery charger, the battery starts to drain then I start to lose my fridge even thou I'm connected to a 30 amp connection at the CG.
Ravens is offline   Reply With Quote
Old 11-24-2011, 07:31 AM   #4
Site Team - Lou
Herk7769's Avatar
Join Date: Oct 2009
Location: South Eastern PA
Posts: 19,831
Can I ask who installed the 30 amp RV outlet?

It totally sounds like it was wired as a 220VAC.
Has it worked before with a previous camper?

If the RV outlet worked previously with a 30 amp camper, then there had to have been a catastrophic failure in the converter.

If not, someone wired your outlet wrong (220VAC vs. 110VAC)

If you applied 220 VAC to your camper, I have very bad news for you.
You are looking at a VERY expensive repair that will not be covered by your warranty. Fuses and circuit breakers will NOT stop an over/under voltage condition (just an over amperage fault). Over voltage will destroy electronics in an instant without tripping any breakers.

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
Herk7769 is online now   Reply With Quote
Old 11-24-2011, 07:37 AM   #5
Senior Member
grhodes50's Avatar
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,597
If your 30 amp hook up is wired correctly, then it does sound like the tt's got something wired wrong somewhere. I would get it back to the dealer so they could check it out and fix whatever it is.
Good luck and keep us posted.

Gary & Trish
"PT Crew Member Since 11/2010"
2017 Prime Time Crusader 315RST TE 6.0 : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2016 Nights Camped - 9
grhodes50 is online now   Reply With Quote
Old 11-24-2011, 02:12 PM   #6
Senior Member
rracer5's Avatar
Join Date: Jan 2011
Location: Full Timing It
Posts: 1,550
When you went through your PDI, did the dealer have the TT plugged in and have everything working? If so, then it sounds loke something jarred loose and shorted between the dealer and home.

"PT Crew Members Since 9/2010"
2011 RAM 2500 HD 6.7L CTD Crew
2014 Sanibel 3250
rracer5 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:18 PM.