Thread Tools Display Modes
Old 06-27-2011, 07:29 PM   #11
Senior Member
j2detroit's Avatar
Join Date: Jul 2007
Location: Detroit Lakes MN home of We Fest
Posts: 304
two weeks ago i bought a winegard mini dish for my camper and while hooking it up i to found that neither of the hookups would work so i drilled a hole into my camper put in a new plate andhooked iy up looks good works great

j2detroit is offline   Reply With Quote
Old 06-29-2011, 05:49 PM   #12
Cyber Phrenologist
Radio's Avatar
Join Date: Jun 2007
Location: Fayetteville, GA
Posts: 1,606
Originally Posted by RV Guy View Post
I know a satellite feed typically won't go thru a splitter or the booster that's why we wire it direct. In the ever-changing world of electronics maybe something else has evolved.
That's only somewhat true. The reality is the DC voltage required to operate the outdoor electronics of the antenna is powered from the set top box via the center conductor of the cable. Most splitters will not pass DC voltage and thus the antenna never gets the power it needs. But some, and you can tell by the price tag, will pass DC from the single port side to ONE PORT ONLY on the multi-port side. You have to look very carefully to make sure the box and antenna are hooked up correctly.

Admin at, part of the Social Knowledge network.
"RVing and Amateur Radio served up on the same plate"
2008 (or is it 2009?) Rockwood 8280SS - 2007 F-150
Lot's of mostly Kenwood radios

Radio is offline   Reply With Quote
Old 06-29-2011, 06:14 PM   #13
Join Date: Jul 2010
Location: Tucson
Posts: 42
This brings up an excellent question for me. I have a 2011 Rockwood 8280WS 5er and have never been able to get campground cable to work on my Toshiba flat screen. Does anyone know if there is a hidden switch somewhere for cable? Over the air works great in both the main cabin and the bedroom.
azwade is offline   Reply With Quote
Old 06-30-2011, 06:54 AM   #14
Commercial Member
Join Date: Jan 2011
Posts: 580
Radio - thanks for the comment. We are investigating with Winegard.
RV Guy is offline   Reply With Quote
Old 07-17-2011, 05:56 PM   #15
New to RV's, not camping
Join Date: Mar 2010
Location: NorthEast
Posts: 15
Speaking of the ever changing complexity.....I have a similar situation. I have a 2011 8317ss and on the outside there is a connection for cable in, and another for satellite. On the inside, right below the main TV in the living room, there is another set of connections for cable and satellite. (Nothing is hooked up to either of these inside.) There is also a "switch" box below that with 4 settings: (GAME), (CABLE/SATELLITE), (MP3/TV), and (XM/ipod). Just above this switch are 3 rows of RCA jacks. The first row is yellow, red, and white labeled (GAME). The second row is also yellow, red, and white and is labeled (CABLE/SATELLITE). The last row of RCA jacks is only red and white and is labeled (MP3/TV). When I plug "cable" in outside, all TV's inside work no matter what the settings are on the switch inside. When I plug the satellite antenna into the satellite in on the outside of the rig, I try switching the switch to (Cable/Satellite), running a cable from the inside Satellite cable connection to the receiver, and running RCA cables into the 3 RCA jacks labeled (Cable/SATELLITE) from the Satellite receiver. I get nothing. After playing with it for quite a while with different settings, I finally did as the person above and went directly from the antenna to the receiver, (through the front door), and then to the bedroom TV and it worked.

I saw above where you mentioned to unplug from cable connection and plug into Satellite connection inside, but there is nothing plugged into the cable connection inside my rig. My main and bedroom TV's must already be wired directly into cable.

I was able to get the bedroom TV off the wall and look behind it, but I can not get the flatscreen off the wall in the living room to look behind it. I assumed you just lift straight up like on the bedroom one, but I tried and it does not seem to budge, and I was afraid I was going to break it. I looked in my manuals and see nothing on hooking this up. Any help would be greatly appreciated.


Explorer777 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:03 AM.