Thread Tools Display Modes
Old 08-04-2014, 12:25 PM   #11
DS ADV Rider
Join Date: Aug 2012
Location: Ontario, Canada
Posts: 154
Really glad to hear your slideout working again. There is a plug-in electrical connector right beside the motor that may be loose but doubt if a bang on the wall would fix it - more likely the opposite, it would fall out. Perhaps the gearbox was "jammed" (mine was seized, I think, from water ingress during winter storage when Ontario had the worst winter in recent history) and the thump freed it. Have the dealer check for signs of rusting around the motor gearbox.

I should clarify, I really like my Lacrosse and have had new trailers before and none are trouble-free - it's just the nature of the industry. They are very light on manufacturing documentation and it seems too much is left up to the individual building the trailer. However, once the initial bugs are out, I've usually had a good experience.


DualSport is offline   Reply With Quote
Old 08-19-2014, 04:26 AM   #12
Senior Member
Mister's Avatar
Join Date: Jun 2013
Posts: 159
Thanks to all who posted info in this thread. I've got a Tracer with a kitchen slide that's not retracting snugly. The lower edge is staying out about an inch. I've got service scheduled and even the tech said over the phone the motor likely at the end of its life and needs replaced. That said I'm braving a trip before the service call. Maybe not the smartest move but with this info I feel I can make a valiant effort at making it home should the worst occur.


2008 F150 FX4 5.4L & 3.73s
2014 PTM Tracer 3200BHT
Yes...I've finally made it to Prime Time!
Mister is offline   Reply With Quote
Old 08-19-2014, 04:41 AM   #13
B and B's Avatar
Join Date: Jun 2013
Location: Wilmot Twp, Ontario, Canada
Posts: 6,764
Originally Posted by shooterguy71 View Post
I got my slide out to go "out" yesterday. All I did was bang my fist against the wall near the motor. I'm not sure if I have a short or something going on in the motor. I will need to get it checked out when I get back to Georgia.

Thanks for all the comments and assistance.
Sound like the moulded barnes is bad, had this happen twice. The femalconenctor has rubber flashing from the moulding process inside. Cleaned the rubber out with a drill bit used as a scrapper. Worked fine after. I did this after the harness was replaced, new one was still bad. Also treated the connector to de-oxit also known as Cramaleon. A contact cleaner that stays put.

B and B
2013 Rockwood 8289 Diamond Edition
GY D's/2.5 inch lift kit/Powerhouse 4 KW EFI Generator
2016 Ford F 350 Lariat Power Stroke Diesel Crew Cab FX4
2008 Golden Falcon 380PA Park Model Model

"Oh Canada,True North Strong and Free!"
B and B is offline   Reply With Quote

slide, slide out

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:19 AM.