Reply
 
Thread Tools Display Modes
Old 02-16-2015, 10:21 PM   #451
Senior Member
 
another_newfie's Avatar
 
Join Date: Feb 2013
Posts: 684
The parts for both main cabin slides have arrived at my dealer. Not bad, about a week from the time I got clearance from PT to have my dealer install them and they have them.


I plan on bringing the unit in to them this coming weekend and dropping it off. I'll be leaving town for work for a few weeks so they have lots of time to do the work.


Tiggerdad, in my case I am almost a year out of warranty. PT did not stall or try and dodge me in any way. I presented with the evidence of the wear, they already knew my unit was experiencing it inside the warranty period anyway. Initially I was going to attend the FROG rally and get it dealt with there, but after that plan fell through I approached them again and they agreed to a dealer fix.
__________________

__________________
2015 F-350 SRW 6.7 PSD
2014 Crusader 295RST

1 Fantastic DW
1 Amazing DD
1 Beagle that will be missed (RIP Zeus)
another_newfie is offline   Reply With Quote
Old 02-17-2015, 06:04 PM   #452
Member
 
Join Date: May 2014
Location: Kilgore, Tx
Posts: 44
Has anyone ever seen these so called slide repair kits or have pictures? My dealer called and wanted me to come look at what the factory sent . I am going in the morning. They only sent one kit. I still haven't heard from the factory rep as of yet.
__________________

__________________
Fufys is offline   Reply With Quote
Old 02-17-2015, 07:23 PM   #453
Site Team
 
Platokidd's Avatar
 
Join Date: Aug 2012
Location: top side land of Lincoln
Posts: 6,432
Thumbs up Yep

Click image for larger version

Name:	IMG_20140523_105627_998.jpg
Views:	279
Size:	330.7 KB
ID:	69823

Click image for larger version

Name:	IMG_20140601_104535_107.jpg
Views:	255
Size:	226.6 KB
ID:	69824

Click image for larger version

Name:	IMG_20140601_104227_894.jpg
Views:	245
Size:	206.2 KB
ID:	69827

Click image for larger version

Name:	IMG_20140601_104323_225.jpg
Views:	241
Size:	177.1 KB
ID:	69828


update

Click image for larger version

Name:	IMG_20140601_104220_805.jpg
Views:	223
Size:	224.7 KB
ID:	69881
__________________
2014 LaCrosse 323RST-TE-C
2009 Chevy 2500HD Z71
nights of camping
2017-67 / 16-92 / 15-73 / 14-60 / 13-33
Seasonal
Platokidd is online now   Reply With Quote
Old 02-18-2015, 11:01 AM   #454
Senior Member
 
another_newfie's Avatar
 
Join Date: Feb 2013
Posts: 684
Thanks for the pics Platokidd. So they wrap up around the edges and they are held in place with adhesive only?
__________________
2015 F-350 SRW 6.7 PSD
2014 Crusader 295RST

1 Fantastic DW
1 Amazing DD
1 Beagle that will be missed (RIP Zeus)
another_newfie is offline   Reply With Quote
Old 02-18-2015, 01:26 PM   #455
Member
 
Join Date: May 2014
Location: Kilgore, Tx
Posts: 44
I went to my dealer and looked at the "fix" that PT has sent to repair and fix the slide wear problem. First of all they sent only one plastic piece, I guess it only takes one for each slide. That fix ill only address the edge wear. My biggest problem is the tearing of the fabric at the center of the under slide. It is really bad on the driver's side, but there is also evidence of tearing on the other slide also.
__________________
Fufys is offline   Reply With Quote
Old 02-18-2015, 01:42 PM   #456
Site Team
 
Platokidd's Avatar
 
Join Date: Aug 2012
Location: top side land of Lincoln
Posts: 6,432
Quote:
Originally Posted by another_newfie View Post
Thanks for the pics Platokidd. So they wrap up around the edges and they are held in place with adhesive only?
Good question, Im not sure if the screws on the side of the slide go thru the strip or not. But it is secure and seems to be holding under the trim piece fine.

Now as to the double side tape that holds to the under side to the fabric.
Mine in one spot on the outside end last fall started to lose it hold.
Fortunately, I had some darco tape laying around and applied a small piece of tape to strip to hold it.

One thing I asked my dealer to do that they didn't, was to install the strip so it would stay in contact with the wear bar and slide bottom at all times.

In other words when my slide is extended, the wear strip doesn't make contact with the wear bar. (or its the other way around, cant remember right now)So when I retract the slide it has to glide up on the wear bar, good thing the bar has a radius on the top. Now thats not a problem yet, but you can bet Im watching closely.

Other then that the wear strips are doing a fine job protecting the area it covers. Which is 90% of where the wear is on my unit.

I use 303 aerospace on the strips and the fabric bottom to keep them clean and slick.
I also use slide slickers on the carpet areas of my unit.

Hope all that made sense...

Added another pic , so maybe the screws do go thru the strips
Slide out /Underside wearing
__________________
2014 LaCrosse 323RST-TE-C
2009 Chevy 2500HD Z71
nights of camping
2017-67 / 16-92 / 15-73 / 14-60 / 13-33
Seasonal
Platokidd is online now   Reply With Quote
Old 02-18-2015, 07:23 PM   #457
Site Team
 
Platokidd's Avatar
 
Join Date: Aug 2012
Location: top side land of Lincoln
Posts: 6,432
Quote:
Originally Posted by Fufys View Post
I went to my dealer and looked at the "fix" that PT has sent to repair and fix the slide wear problem. First of all they sent only one plastic piece, I guess it only takes one for each slide. That fix ill only address the edge wear. My biggest problem is the tearing of the fabric at the center of the under slide. It is really bad on the driver's side, but there is also evidence of tearing on the other slide also.
Had this wear mark in the center of my slide.
Click image for larger version

Name:	IMG_20130813_171241_642.jpg
Views:	211
Size:	140.2 KB
ID:	69885
Thought it could be caused by this section of the flooring
Click image for larger version

Name:	IMG_20130813_171709_947.jpg
Views:	225
Size:	168.8 KB
ID:	69886

But I have a hunch it may have been cause by the heat vent in the floor. Its close to being in line (I think) So I changed / upgraded the vent to one that can be closed and it sits in the hole better.
__________________
2014 LaCrosse 323RST-TE-C
2009 Chevy 2500HD Z71
nights of camping
2017-67 / 16-92 / 15-73 / 14-60 / 13-33
Seasonal
Platokidd is online now   Reply With Quote
Old 02-19-2015, 05:30 AM   #458
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 7,624
Quote:
Originally Posted by Platokidd View Post
Had this wear mark in the center of my slide.
Attachment 69885
Thought it could be caused by this section of the flooring
Attachment 69886

But I have a hunch it may have been cause by the heat vent in the floor. Its close to being in line (I think) So I changed / upgraded the vent to one that can be closed and it sits in the hole better.
I would go buy my own plastic and install it over that area. I had that same problem and found that the screw head holding down the wear strip was sticking up. I removed the wear strip and counter sunk the holes and moved it over one inch. It ended my problem. I know it wasn't from my register because they are in the center of the unit. Not sure were your registers are located. Seems we been fighting this crap forever, just a poor design and poor fix's by the factory. Mine was the exact same place on my Rockwood.
__________________
Rockwood #8289 WS 2012
F250 6.0 / Husky 16k
With 4 point leveling system
Witch Doctor is online now   Reply With Quote
Old 02-20-2015, 08:13 PM   #459
Member
 
Join Date: Jun 2014
Location: Denham Springs, Louisiana
Posts: 48
Looks like PT is closed or out of business. Both my dealer and I have been trying to call them and no one is answering the phones. Looks like I may have to fix my camper myself.
__________________
10 Chevy Silverado 3500 CrewCab
6.6L Duramax with EFI Live Tuner with 5 levels
560hp 958 Max torque 3:73 gears
2015 Crusader 351REQ
cajun225 is offline   Reply With Quote
Old 02-20-2015, 11:38 PM   #460
Site Team
 
Platokidd's Avatar
 
Join Date: Aug 2012
Location: top side land of Lincoln
Posts: 6,432
Quote:
Originally Posted by cajun225 View Post
Looks like PT is closed or out of business. Both my dealer and I have been trying to call them and no one is answering the phones. Looks like I may have to fix my camper myself.
caller I.D. JK.. Sounds kinda odd, what number are you calling?
574-862-1025
__________________

__________________
2014 LaCrosse 323RST-TE-C
2009 Chevy 2500HD Z71
nights of camping
2017-67 / 16-92 / 15-73 / 14-60 / 13-33
Seasonal
Platokidd is online now   Reply With Quote
Reply

Tags
slide, slide out

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:41 AM.