Reply
 
Thread Tools Display Modes
Old 05-08-2011, 10:18 AM   #1
Senior Member
 
tbritt's Avatar
 
Join Date: Mar 2011
Location: Antlers Ok
Posts: 172
Up date 303rk

Well the new breaker the Dealer put in didn't make it past it's first 90 degee Texas day.....Guess we'll put the Frig and Water heater both on gas to see if it will hang in there until the Dealer/PT get it all worked out, other than that it's the same ol story,Parts on order checks in the mail!!!Happy Mothers Day to all the PT DW's
__________________

__________________
2012 GMC 2500 HD
2011 303 RK LaCrosse Luxury Lite
Days camped 2010: 274
2011: 365
2012: 365
tbritt is offline   Reply With Quote
Old 05-08-2011, 12:31 PM   #2
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,613
I'm not much on electrical problems, but I do know they can be hard to trace down. I would think replacing the breaker would be the easiest and probably the first thing to try. After that, I guess just take things one at a time until whatever is tripping the breaker can be found. Time comsuming and not always easy to do.
Hang in there and I hope they find the problem soon.

I found out why my dealer hadn't ordered the parts. The service manager has been out because of serious illness. He hadn't ordered the parts yet and no one could find the list. He's back now and the parts were ordered the other day. Just one of those things. At least the service manager is doing well enough to be back at work.
__________________

__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2017 Prime Time Crusader 315RST TE 6.0 : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2017 Nights Camped - 4
grhodes50 is offline   Reply With Quote
Old 05-08-2011, 12:33 PM   #3
Senior Member
 
rracer5's Avatar
 
Join Date: Jan 2011
Location: Full Timing It
Posts: 1,902
Quote:
Originally Posted by tbritt View Post
Well the new breaker the Dealer put in didn't make it past it's first 90 degee Texas day.....Guess we'll put the Frig and Water heater both on gas to see if it will hang in there until the Dealer/PT get it all worked out, other than that it's the same ol story,Parts on order checks in the mail!!!Happy Mothers Day to all the PT DW's

Sounds like it's time for a new Power Center.

BTW ..... Did you get my answer to your post about your need for a TV mount?
__________________
"PT Crew Members Since 9/2010"[/I][/B]
2011 RAM 2500 HD 6.7L CTD Crew
2014 Sanibel 3250
rracer5 is offline   Reply With Quote
Old 05-08-2011, 04:08 PM   #4
Senior Member
 
M109Rrider's Avatar
 
Join Date: Oct 2010
Location: Chesapeake, Va
Posts: 877
May or may not be the right answer and/or what you want to hear but my old trailer was the same way. I had to limit what electrical stuff would be on at the same time as the A/C. I couldn't run the A/C and water heater and I had to make sure the coffee pot was off before using the microwave. The problem I had was when the A/C cycled. If I used the stuff while the A/C was already running it wasn't a problem. But if the A/C was off and cycled on the initial current draw would trip the breaker. I had to accept that's the way it was and got used to it.
__________________

Jason and Billie
2005 Dodge Ram 2500, 4X4, QC/SB 5.9L Cummins
15k non-sliding Hidden Hitch (they lied, it's not hidden at all)
2011 Prime Time Crusader 320RLT
"PT Crew Member Since 11/2010"
M109Rrider is offline   Reply With Quote
Old 05-09-2011, 08:05 AM   #5
Senior Member
 
Join Date: Mar 2011
Posts: 325
Quote:
Originally Posted by tbritt View Post
Well the new breaker the Dealer put in didn't make it past it's first 90 degee Texas day.....Guess we'll put the Frig and Water heater both on gas to see if it will hang in there until the Dealer/PT get it all worked out, other than that it's the same ol story,Parts on order checks in the mail!!!Happy Mothers Day to all the PT DW's
Is it the power source or does the AC or Frig have issues? Did anyone hook them up to make sure they are working properly?
__________________
2011 Lacrosse 318BHS Touring Edition
2012 Ford F150 SupCrew 4x4 XLT 6.5' Max Tow
padave65 is offline   Reply With Quote
Old 05-09-2011, 09:41 AM   #6
Senior Member
 
tbritt's Avatar
 
Join Date: Mar 2011
Location: Antlers Ok
Posts: 172
Quote:
Originally Posted by rracer5 View Post
Sounds like it's time for a new Power Center.

BTW ..... Did you get my answer to your post about your need for a TV mount?
Yes and thanks I just haven't got to call Brandon with all thats going on the TV mount went on the back burner, but will call him
__________________
2012 GMC 2500 HD
2011 303 RK LaCrosse Luxury Lite
Days camped 2010: 274
2011: 365
2012: 365
tbritt is offline   Reply With Quote
Old 05-09-2011, 09:55 AM   #7
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
Just curious, do you have a 13.5 or 15k A/C unit? If it is a 15k maybe too much current on the cct with the water heater.
__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Old 05-09-2011, 10:02 AM   #8
Senior Member
 
tbritt's Avatar
 
Join Date: Mar 2011
Location: Antlers Ok
Posts: 172
Quote:
Originally Posted by TheSasks View Post
Just curious, do you have a 13.5 or 15k A/C unit? If it is a 15k maybe too much current on the cct with the water heater.
Yep it's a 15K but you would think if they tested all the systems and ran across a issue they would have made this trailer a 50 amp. It makes sence that you should have no trouble with the 3 big draw items A/C,Frig and Water heater??
__________________
2012 GMC 2500 HD
2011 303 RK LaCrosse Luxury Lite
Days camped 2010: 274
2011: 365
2012: 365
tbritt is offline   Reply With Quote
Old 05-09-2011, 10:15 AM   #9
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,613
I have the same tt as you, but I haven't camped needing to run the AC yet. I have ran the furnance without issues, but that's not the same as the AC.
I will be camping in a couple of weeks and I anticipate I will be running the AC then. I will let you know if I have the same issues you are experiencing.
__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2017 Prime Time Crusader 315RST TE 6.0 : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2017 Nights Camped - 4
grhodes50 is offline   Reply With Quote
Old 05-09-2011, 10:38 AM   #10
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
FYI
  • Air Conditioner 15-17 amps
  • Refrigerator 5.7 amps
  • Electric Water Heater 12.5 amps
  • Microwave Oven 12.8 amps
  • Electric Coffee Pot 9 amps
  • Toaster 10 amps
  • Hair Dryer 10-12 amps
  • TV 2 amps
  • Dirt Devil Hand Vacuum 2 amps
  • Electric Fry Pan 10 amps
  • Iron 10 amps
  • Food Processor 6 amps
  • Crock Pot 1.5 amps
  • Heating Pad 0.5 amps
  • 1,100 Watt Heater 10 amps
  • Laptop computer 2-3 amps
__________________

__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:21 PM.