Reply
 
Thread Tools Display Modes
Old 11-03-2014, 01:41 PM   #1
Senior Member
 
Join Date: Jun 2013
Location: Katy, Tx
Posts: 186
Weird sound in Crusader furnace?

Sorry for all of the questions guys and thank you for bearing with me.

This is my 3rd RV and I know all furnaces are just plain loud so this may be completely normal. Anyways, this furnace, the fan has this weird high pitch noise while running. I can't really describe it but I have a link to a video I took yesterday.

The furnace performs as it should and it won't bother me as long as I know it is completely safe. I tend to be a worry wart about the furnace and I just lay there imagining the worst!

Crusader heater - YouTube
__________________

__________________
2015 Crusader 315rst
2016 Ford F350 SRW 4x4 King Ranch 6.7L
Houstonkid is offline   Reply With Quote
Old 11-03-2014, 02:33 PM   #2
Member
 
RossandDonna's Avatar
 
Join Date: Jun 2011
Location: Northwest Illinois
Posts: 71
Check your blower motor it sounds like something is rubbing the blower cage like a leaf or piece of plastic etc.
__________________

__________________

2012 Crusader 290RLT
2013 F350 Lariat Crew Cab DRW 6.7L Diesel
RossandDonna is offline   Reply With Quote
Old 11-03-2014, 03:03 PM   #3
Mddle of the Rd Extremist
 
MeepMeep's Avatar
 
Join Date: Feb 2014
Location: Jacksonville, FL
Posts: 540
Quote:
Originally Posted by Houstonkid View Post
Sorry for all of the questions guys and thank you for bearing with me.

This is my 3rd RV and I know all furnaces are just plain loud so this may be completely normal. Anyways, this furnace, the fan has this weird high pitch noise while running. I can't really describe it but I have a link to a video I took yesterday.

The furnace performs as it should and it won't bother me as long as I know it is completely safe. I tend to be a worry wart about the furnace and I just lay there imagining the worst!

Crusader heater - YouTube
Just noticed the same high pitched noise in our CC 38FL.....had me rubbing my chin for a while 'til DW said she thought it was coming from the sound system. So we turned the sound system off and the high pitched sound went away - turned it back on and there it was again. Got a feeling there's a bad ground somewhere, but don't have time to chase it right now

Let me know what you find with yours, if you would be so kind

Thanks, Dan
__________________
Dan, Carolyn & The Bandit (1999-2015 RIP...)
MCPO (Retired)
United States Navy ('65 - '87)
2014 Cedar Creek 38FL
2013 RAM 3500 6.7L diesel DRW Crew Cab
"When you get to the fork in the road, take it....."
MeepMeep is offline   Reply With Quote
Old 11-03-2014, 03:09 PM   #4
Senior Member
 
Join Date: Jun 2013
Location: Katy, Tx
Posts: 186
Thanks guys, I will look into both suggestions. I guess a follow up question for you guys.

Does that sound bother you enough you wouldn't run the furnace? Like I posted earlier, it is functioning properly, fan starts, then the delay, then ignition and or course the opposite when it hits temp.
The trailer is out at the deer lease and getting it to a shop isn't feasible right now.
__________________
2015 Crusader 315rst
2016 Ford F350 SRW 4x4 King Ranch 6.7L
Houstonkid is offline   Reply With Quote
Old 11-03-2014, 03:23 PM   #5
Member
 
RossandDonna's Avatar
 
Join Date: Jun 2011
Location: Northwest Illinois
Posts: 71
I guess that is up to you and how much it bothers you, it beats freezing. If you have some tools with you open up the furnace compartment get to the blower motor and poke your head in there to see what's cooking it may be something obvious and easy.
__________________

2012 Crusader 290RLT
2013 F350 Lariat Crew Cab DRW 6.7L Diesel
RossandDonna is offline   Reply With Quote
Old 11-03-2014, 03:38 PM   #6
Senior Member
 
Join Date: Jun 2013
Location: Katy, Tx
Posts: 186
Thanks R&D, I will get in and dig around when I go back Saturday. Hopefully I can spot something.
__________________
2015 Crusader 315rst
2016 Ford F350 SRW 4x4 King Ranch 6.7L
Houstonkid is offline   Reply With Quote
Old 11-03-2014, 03:48 PM   #7
Mddle of the Rd Extremist
 
MeepMeep's Avatar
 
Join Date: Feb 2014
Location: Jacksonville, FL
Posts: 540
Quote:
Originally Posted by Houstonkid View Post
Thanks guys, I will look into both suggestions. I guess a follow up question for you guys.

Does that sound bother you enough you wouldn't run the furnace? Like I posted earlier, it is functioning properly, fan starts, then the delay, then ignition and or course the opposite when it hits temp.
The trailer is out at the deer lease and getting it to a shop isn't feasible right now.
The sound bothers us enough that we're not turning on the stereo when we need to run the furnace. The furnace noise when the stereo is off is just as typically noisy as it was in our last 5'er, so we don't have any problem running the furnace
__________________
Dan, Carolyn & The Bandit (1999-2015 RIP...)
MCPO (Retired)
United States Navy ('65 - '87)
2014 Cedar Creek 38FL
2013 RAM 3500 6.7L diesel DRW Crew Cab
"When you get to the fork in the road, take it....."
MeepMeep is offline   Reply With Quote
Old 11-03-2014, 04:00 PM   #8
Senior Member
 
Join Date: Jun 2013
Location: Katy, Tx
Posts: 186
Quote:
Originally Posted by MeepMeep View Post
The sound bothers us enough that we're not turning on the stereo when we need to run the furnace. The furnace noise when the stereo is off is just as typically noisy as it was in our last 5'er, so we don't have any problem running the furnace
Sorry, I may have worded that wrong, I meant does the sound concern you guys enough to not run the heater for safety purposes. This sound happens whether the radio is on or not. I agree it does sound like some type of electrical interference but I am pretty sure this is a mechanical sound coming directly from the compartment where the heater resides.
__________________
2015 Crusader 315rst
2016 Ford F350 SRW 4x4 King Ranch 6.7L
Houstonkid is offline   Reply With Quote
Old 11-03-2014, 04:07 PM   #9
Mddle of the Rd Extremist
 
MeepMeep's Avatar
 
Join Date: Feb 2014
Location: Jacksonville, FL
Posts: 540
Quote:
Originally Posted by Houstonkid View Post
Sorry, I may have worded that wrong, I meant does the sound concern you guys enough to not run the heater for safety purposes. This sound happens whether the radio is on or not. I agree it does sound like some type of electrical interference but I am pretty sure this is a mechanical sound coming directly from the compartment where the heater resides.
In that case, I would err on the side of caution. Mine is ONLY there when we run both stereo and furnace at the same time. If I were hearing it all the time that the furnace was running, I'd have my head inside that furnace til I figured it out. Thanks for clarifying and good luck finding the problem
__________________
Dan, Carolyn & The Bandit (1999-2015 RIP...)
MCPO (Retired)
United States Navy ('65 - '87)
2014 Cedar Creek 38FL
2013 RAM 3500 6.7L diesel DRW Crew Cab
"When you get to the fork in the road, take it....."
MeepMeep is offline   Reply With Quote
Old 11-03-2014, 04:25 PM   #10
Senior Member
 
Join Date: Jun 2013
Location: Katy, Tx
Posts: 186
BTW, thank you for your service sir.
__________________

__________________
2015 Crusader 315rst
2016 Ford F350 SRW 4x4 King Ranch 6.7L
Houstonkid is offline   Reply With Quote
Reply

Tags
crusader, furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:35 AM.