Reply
 
Thread Tools Display Modes
Old 02-21-2012, 02:54 PM   #1
Junior Member
 
Join Date: Jan 2012
Posts: 10
2012 Catalina Deluxe 28DDS

We took delivery of our new trailer yesterday. Purchased from Trade Winds RV in Clio MI. Nothing but positive things to say about the dealer. They did a great job prepping the trailer and taking us thru a demo. My only concern was towing this 6,000lb (empty) trailer with our 2003 1/2 ton Yukon. Turns out the Yukon did fine, experienced a little bit of sway at times but nothing major. Upon arriving home and detaching the sway bar I realized it wasn't working at all. The threads had been stripped and there wasn't any pressure being applied to the friction pads. The trailer is gorgeous, we can't wait to begin camping.
__________________

__________________
kj4278 is offline   Reply With Quote
Old 05-05-2012, 04:51 PM   #2
Member
 
Join Date: Nov 2011
Location: Indiana
Posts: 39
Congrats KJ!!! Sorry about the sway bar. I hope that they are helping or replacing those. They are not cheap and especially if you just bought a travel trailer! Let the fun times come with the TT!!!
__________________

__________________
2012 Coachmen Catalina Deluxe Edition 28DDS
2002 Cadillac Escalade
St1tcher is offline   Reply With Quote
Old 05-05-2012, 11:24 PM   #3
Senior Member
 
steeleshark2's Avatar
 
Join Date: Aug 2008
Posts: 228
Congrats on your new trailer. Get that sway bar fixed and get out and enjoy your new camper as soon as possible.
__________________
steeleshark2 is offline   Reply With Quote
Old 05-05-2012, 11:45 PM   #4
Member
 
pbrackney's Avatar
 
Join Date: Feb 2012
Location: Michigan
Posts: 319
Quote:
Originally Posted by kj4278
We took delivery of our new trailer yesterday. Purchased from Trade Winds RV in Clio MI. Nothing but positive things to say about the dealer. They did a great job prepping the trailer and taking us thru a demo. My only concern was towing this 6,000lb (empty) trailer with our 2003 1/2 ton Yukon. Turns out the Yukon did fine, experienced a little bit of sway at times but nothing major. Upon arriving home and detaching the sway bar I realized it wasn't working at all. The threads had been stripped and there wasn't any pressure being applied to the friction pads. The trailer is gorgeous, we can't wait to begin camping.
Welcome from another Michigander.
__________________
Philip, DW, 3 DD, 1 DS, and Ginger our Dog
2017 Wildwood 30QBSS
2003 Ford Expedition 5.4 Liter with 3.73 Axle
Equalizer 4-Point Sway 12000# & Tekonsha P3
pbrackney is offline   Reply With Quote
Old 05-06-2012, 09:47 AM   #5
Junior Member
 
Join Date: May 2012
Posts: 14
picked our up yesterday as well same trailer, with the same concerns but 06 f150 did great as well, awesome triler
__________________
spud7378 is offline   Reply With Quote
Old 05-09-2012, 11:00 AM   #6
Junior Member
 
mtusrsmith's Avatar
 
Join Date: Feb 2012
Location: Illinois
Posts: 14
I also have the same trailer, loved it until last week. Still do, I suppose, pending the outcome of my electrical problems. I have posted some pictures and my TV installation as wall as my recent problems, if you are interested and resourceful you can find them.
__________________

__________________
mtusrsmith is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:29 PM.