Reply
 
Thread Tools Display Modes
Old 09-21-2016, 03:28 PM   #1
Senior Member
 
Join Date: Oct 2013
Location: Queen Creek, Arizona
Posts: 128
dometic toilet

Just went to rinse my dometic toilet, pushed down the pedal, no water, none.
have water up to the toilet, none after that. Not even a drip. Seems if there were something blocking the line I would get something.

Anyone experience this yet? Pedal seem to work o.k. Going to call dometic but thought I'd try here first.

Thanks,
Jim

__________________

jpaskell is offline   Reply With Quote
Old 09-21-2016, 03:47 PM   #2
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 7,128
Clean the valve. Most likely got some debris clogging things up. Easy to do.
__________________

__________________
2016 Georgetown 364TS
2017 Jeep Rubicon Recon toad
Nights Camped 2019 - 17
AquaMan is offline   Reply With Quote
Old 09-21-2016, 08:46 PM   #3
Senior Member
 
Join Date: Oct 2013
Location: Queen Creek, Arizona
Posts: 128
Thanks AquaMan, I found some other threads that explain the procedure pretty well.
I appreciate the note.
Jim
jpaskell is offline   Reply With Quote
Reply

Tags
dometic

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:08 PM.


×