Reply
 
Thread Tools Display Modes
Old 05-05-2014, 05:45 PM   #1
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
What am I doing?

Just a Newby here wondering if anyone knows how long it takes for the hot water to heat up in a 2014 Freedom Express LE 320bhds? De winterizing and getting ready for our first trip and aside of dealer not winterizing it I'm thinking I did something wrong. Purged replaced caps turned the valve under the bed and turned on the switch. What am I missing?

Sent from my SPH-L720 using Forest River Forums mobile app
__________________

__________________
JonClark is offline   Reply With Quote
Old 05-05-2014, 05:47 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Is the water heater full?
Only way to properly check is to flip open the relief valve.


TURBS

Sabre owners united!
__________________

__________________
TURBS is offline   Reply With Quote
Old 05-05-2014, 05:48 PM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
This.

If it's not full you may have burnt the element out.

TURBS

Sabre owners united!
Attached Images
 
__________________
TURBS is offline   Reply With Quote
Old 05-05-2014, 05:51 PM   #4
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
Thanks will try my luck at this now. Was hoping to have no issues but after a torn floor at delivery plus laundry list and now outside shower leaks from not being winterized, this will kill the wife's spirit

Sent from my SPH-L720 using Forest River Forums mobile app
__________________
JonClark is offline   Reply With Quote
Old 05-05-2014, 05:56 PM   #5
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
Checked the relief valve, tank seams to be full. Guess I will give it a little while longer. Thanks f1100turbo.

Sent from my SPH-L720 using Forest River Forums mobile app
__________________
JonClark is offline   Reply With Quote
Old 05-05-2014, 05:59 PM   #6
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,028
Quote:
Originally Posted by JonClark View Post
Just a Newby here wondering if anyone knows how long it takes for the hot water to heat up in a 2014 Freedom Express LE 320bhds? De winterizing and getting ready for our first trip and aside of dealer not winterizing it I'm thinking I did something wrong. Purged replaced caps turned the valve under the bed and turned on the switch. What am I missing?

Sent from my SPH-L720 using Forest River Forums mobile app
You need to always make sure the heater is full of water before turning on ANY switch.

Couple questions:

1. A: what brand water heater do you have?

B. If a dual powered Suburban brand.... When you said you turned on switch, is it the switch for the DSI/propane OR the electric heating element? If you just went "huh", then this may help:

Suburban's electric switch and much more

The water heater just using propane, will average around 15 minutes to heat a tank, but this time will vary depending on how cold the initial water in the tank is. You have to have propane tanks with fuel and the valves opened...to use this function.

If using the electric heating element only, it usually takes a little longer, but you must be hooked up to a form of 120 volt shore power for this side to work.
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 05-05-2014, 06:04 PM   #7
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
It is an Atwood dual fire heater. Tried on gas pilot lights but when I try it on electric I don't hear anything. Can't imagine it's that quiet

Sent from my SPH-L720 using Forest River Forums mobile app
__________________
JonClark is offline   Reply With Quote
Old 05-05-2014, 06:06 PM   #8
Senior Member
 
wingedone's Avatar
 
Join Date: May 2012
Location: Charlotte, MI
Posts: 210
Just in case:
__________________
2011 Brookstone 354TS
2013 F350 SC 6.7 DRW
Swivelwheel 58DW
wingedone is offline   Reply With Quote
Old 05-05-2014, 06:11 PM   #9
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
I got hot water!!! Thank you all. Sure I will have more questions but thanks for the quick responses. Hoping for happy trails

Sent from my SPH-L720 using Forest River Forums mobile app
__________________

__________________
JonClark is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:56 AM.