Reply
 
Thread Tools Display Modes
Old 05-16-2013, 04:20 PM   #1
Junior Member
 
Join Date: Nov 2012
Posts: 16
Landing gear issues

I have a 2013 Columbus 320RS Fifth wheel. On our second trip out we experienced a loud squeeling sound when lowering the landing gear after retracting the 6 point leveling system. I was raising the camper to hook up the truck.

When I arrived home and started the Auto Drop on the landing gear only and one leg started down. I hit the panic stop and raised it manually, then lowered in the manual mode and both legs came down.

This is my first Fifth Wheel and was not sure if I had done something wrong or there is something wrong with the landing gear motors.

We are leaving on a week long trip next Monday and I am a little apprehensive about the landing gear.

Has anyone else experienced anything like this?
__________________

__________________
ee2810 is offline   Reply With Quote
Old 05-16-2013, 04:36 PM   #2
Denver, CO
 
garbonz's Avatar
 
Join Date: Jan 2013
Location: Denver, CO
Posts: 1,905
Did you run them up to the top until they stopped and clicked? If so you may have broken the jack screw, If you can crank them manually then it has to be the motor or controller. Back to the dealer fer sure.

PS. always carry a bottle or floor jack for these instances.
__________________
2007 Chevy 2500HD Classic LBZ Duramax/Allison (Stock)
2005 Bigfoot 1500C8.2 AWESOME
garbonz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:15 PM.