Reply
 
Thread Tools Display Modes
Old 07-17-2015, 04:05 PM   #1
Junior Member
 
Join Date: Dec 2014
Posts: 13
Send a message via ICQ to sular47
2011 forest river georgetown

My hot water heater will heat for a minute then nothing for hours, I have replace the Hi--Tstat switch twice. I have 120 volts to one side of the Hi switch now with a new switch. It will not reset to let the power go through. I jumper the switch and still no power to the element. The gas side will not work as well. The red ignition light never comes on....could the module be bad causing thid problem? This is a Suburban heater 4 years old!
__________________

__________________
sular47 is offline   Reply With Quote
Old 07-17-2015, 06:26 PM   #2
Junior Member
 
Join Date: Dec 2014
Posts: 13
Send a message via ICQ to sular47
fixed it ...valves were in the wrong position!!!
__________________
sular47 is offline   Reply With Quote
Reply

Tags
2011, forest river, georgetown

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:15 AM.