Reply
 
Thread Tools Display Modes
Old 05-29-2012, 11:48 PM   #1
Junior Member
 
Join Date: May 2012
Posts: 6
2012 shamrock water heater

Hello I have just purchased a 2012 forest river shamrock 233s trailer and i am new to this type of trailer and the water heater system since it is both electric and propane. So my problem is that when connected to shore power the water heater works well but when trying to hit the switch on the control panel to toggle to propane nothing. The switch just flops back and forth just like a dead switch and no hot water. Now on the control panel when switch's are on they light up right ?. Please help As i Am going to do a lot of boon docking..
__________________

__________________
alovato28 is offline   Reply With Quote
Old 05-29-2012, 11:52 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
when hooked to shore power are you using the "electric" side of the hw heater ?
My switch lights up up but some may not . For propane there also should be a "dsi" light .
how are you turning on the electric side ?
When you hit the propane switch do you hear a click both ways ?
__________________

__________________
TURBS is offline   Reply With Quote
Old 05-29-2012, 11:59 PM   #3
Junior Member
 
Join Date: May 2012
Posts: 6
so when on shore power i have the wh switch on and when trying to switch to propane it is off with little cotter pin in and i go to switch interior panel switch on but nothing it just flops up and down.
__________________
alovato28 is offline   Reply With Quote
Old 05-30-2012, 12:03 AM   #4
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
sounds to me like the switch is broken .
I would suggest pulling it out and testing it .
__________________
TURBS is offline   Reply With Quote
Old 05-30-2012, 12:07 AM   #5
Junior Member
 
Join Date: May 2012
Posts: 6
so it should lite up in propane mode? cause the rest of the switches lite up but not this one lol. I haven't even taken it out yet went from the dealer ship to my house thats as far as i got so far.... Thank you i will try testing first..
__________________
alovato28 is offline   Reply With Quote
Old 05-30-2012, 12:09 AM   #6
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
If it looks like it "should" light up then yes it should .
If the switch is red in color most likely it should glow red when on .

pics of your setup would be helpful.
__________________
TURBS is offline   Reply With Quote
Old 05-30-2012, 12:16 AM   #7
Junior Member
 
Join Date: May 2012
Posts: 6
working on that pic now but you have already been a big help thanks. I will still post pics . Thanks again
__________________
alovato28 is offline   Reply With Quote
Old 05-30-2012, 12:16 AM   #8
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
no problem alovato
__________________
TURBS is offline   Reply With Quote
Old 05-30-2012, 12:21 AM   #9
Moderator Emeritus
 
Join Date: Nov 2008
Location: Winston-Salem, NC
Posts: 2,381
For the water heater, the outside switch, with the little hair pin, is electric only. The inside switch, is for propane only. You can run both at the same time. As for the inside switch, move it one direction, and stand back and wait. Wait some more, and watch for the light. The light will only come on while trying to light. If all is successful, it will go back out. The sequence may take 3o seconds or longer. If the light stays on, you have a failure to light, and will have to troubleshoot that. It will not happen the moment you press the switch, you must wait. Most of the switches I see now days, the factory has in upside down, down is on, up is off. Try it both ways.

For a guarantee failure, try to light it with the propane bottles turned off. After a few minutes the light should be steady glow, indicating failure. That will be the "on" position for propane.
__________________
LadyWindrider
2012 Ford F250 ext. Cab 4x4
2002 Jeep Wrangler Sahara
2008 Yamaha V-Star 650 Classic

2008 Work and Play 18LT
LadyWindrider is offline   Reply With Quote
Old 05-30-2012, 12:37 AM   #10
Junior Member
 
Join Date: May 2012
Posts: 6
Thanks wind rider but turbo was right about a broken i just pulled off the control panel and got a hand full of broken plastic bit's.. Going back to the dealership in the morning... Man so sad i was all loaded up to leave.... : (
__________________

__________________
alovato28 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:32 PM.