Reply
 
Thread Tools Display Modes
Old 10-18-2010, 08:54 AM   #1
Junior Member
 
Join Date: Oct 2010
Posts: 10
Black water tank pressurizing?

hello all, new to the forum. We have a 2007 Cardinal and after emptying our black water tank this past weekend (and using the power flush to rinse it out), we are experiencing an issue with our toilet where when you flush, an air bubble appears when you depress the foot pedal. Even with the black water valve opened, it is still acting like the tank is not venting properly. Has anyone experienced something like this? Does anyone know if it's possible for the vent to get clogged? Any information will be greatly welcomed. Thank you
__________________

__________________
2004 Chevy 3500 Silverado Dually w/Duramax
2007 Forest River Cardinal
bdyates is offline   Reply With Quote
Old 10-18-2010, 04:37 PM   #2
Senior Member
 
Join Date: Aug 2009
Location: New Mexico
Posts: 201
It can .but not very common. You may just want to run a hose to your vent up top & flush the vent stack with dump open if you can? See if that helps.
__________________

__________________
2010 wildcat 31ts
05 Ford F350 SD PS
camprat is offline   Reply With Quote
Old 10-18-2010, 05:10 PM   #3
Senior Member
 
NWJeeper's Avatar
 
Join Date: Aug 2008
Location: Enumclaw, WA
Posts: 2,617
Quote:
Originally Posted by camprat View Post
It can .but not very common. You may just want to run a hose to your vent up top & flush the vent stack with dump open if you can? See if that helps.
X2
__________________
"I can fix it, and if I can't fix it, I can fix it so no one can fix it!"
Ed & Wendy
2009 Georgetown 378TS | 1998 Jeep Wrangler | 1998 Skeeter ZX202C
Nights camped in 2009: 53 | Nights camped in 2010: 55
www.nwjeepn.com
NWJeeper is offline   Reply With Quote
Old 10-20-2010, 02:39 PM   #4
Junior Member
 
Join Date: Oct 2010
Posts: 10
thanks camprat and NWJeeper for your ideas. As it turns out (and I am embarassed to report), all it was was a blockage at the bottom of the pipe beneath the toilet. Depsite us using the tank's power flusher, I guess we did not let it run long enough and it left a buildup behind. I borrowed my fathers flushing wand and gave it a thorough flushing - everything is working fine now.
__________________
2004 Chevy 3500 Silverado Dually w/Duramax
2007 Forest River Cardinal
bdyates is offline   Reply With Quote
Old 10-20-2010, 05:34 PM   #5
Senior Member
 
Join Date: Aug 2009
Location: New Mexico
Posts: 201
Glad to see it all work out. Happy camping!
__________________
2010 wildcat 31ts
05 Ford F350 SD PS
camprat is offline   Reply With Quote
Old 10-20-2010, 05:40 PM   #6
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Quote:
Originally Posted by camprat View Post
Glad to see it all work out. Happy camping!
x2 !!!
__________________

__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Reply

Tags
black water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:34 AM.