Reply
 
Thread Tools Display Modes
Old 01-10-2013, 06:37 PM   #1
10Isola
 
Join Date: Jun 2011
Location: Bucks County, PA
Posts: 80
Blown water pump?

Looking for some insight. I was late winterizing this year and fearful I've ruined my water pump. It hasn't been too cold this year, but we have had some cold nights this year. When I went to pump antifreeze I noticed a good sized leak from the top seal of the pump as the pump started. It lasted a few seconds and since have not had a problem. Perhaps I had some ice in there. Haven't found too much info searching the site. Worried I did some non repairable damage, and afraid to dismantle it. Any advice would be appreciated. Thanks.
__________________

__________________
10Isola is offline   Reply With Quote
Old 01-10-2013, 06:44 PM   #2
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,359
Quote:
Originally Posted by 10Isola View Post
Looking for some insight. I was late winterizing this year and fearful I've ruined my water pump. It hasn't been too cold this year, but we have had some cold nights this year. When I went to pump antifreeze I noticed a good sized leak from the top seal of the pump as the pump started. It lasted a few seconds and since have not had a problem. Perhaps I had some ice in there. Haven't found too much info searching the site. Worried I did some non repairable damage, and afraid to dismantle it. Any advice would be appreciated. Thanks.

So are you saying it still leaks from the top seal any time you turn it on?

The motor and pump assembly is 2 parts and has a gasket in between.
Have you tried tightening ut up? It really isn't much in there.
Here is a picture of the assembly breakdown for mine as well as the manual which may help.
Attached Thumbnails
Click image for larger version

Name:	wind-sun_2216_16142899.jpg
Views:	32
Size:	28.1 KB
ID:	22847  
Attached Files
File Type: pdf My_Pump_4008-101-A65.pdf (143.0 KB, 11 views)
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:36 PM.