Reply
 
Thread Tools Display Modes
Old 09-16-2012, 05:14 PM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 15
Chemical smell and taste to potable water?

Sorry, guys. I'm absolutely new to tt's and I have a question. I recently bought a 2009 Microlite and I filled the potable water from a good water supply with a new designated hose. Upon trying to use it, found that it had a strong chemical smell and taste to it. Any ideas on the cause and/or the cure? Thanks in advance for any and all responses. Rick
__________________

__________________
2004 GMC Safari XLE
2009 Flagstaff 18FBRS MicroLite
sidecar is offline   Reply With Quote
Old 09-16-2012, 05:32 PM   #2
Senior Member
 
papap's Avatar
 
Join Date: Apr 2011
Location: Southwest Louisiana
Posts: 729
Smell

It may have been winterized. Try flushing the tank a few times?
__________________

__________________
2016 Forester 3171DS
Work 28 and 28 around the world.
Camp every chance we get

papap is offline   Reply With Quote
Old 09-16-2012, 05:40 PM   #3
AKA Bluebird
 
dimurrrw's Avatar
 
Join Date: Aug 2006
Location: Charlottesville, VA
Posts: 1,061
Send a message via Yahoo to dimurrrw
Try hooking up the hose and tasting the water coming out of it. In the past I have noticed that some potable water hoses impart a strong taste/smell to the water until they have "seasoned".
__________________
Happy Camping! ///// Richard D.
2006 4x4 Ford 250 SD / 2007 Flagstaff 827 FLS
One very patient wife and one furry child who travels with us. Forty-two years of trailering and camping, and I still have a blast.

dimurrrw is offline   Reply With Quote
Old 09-16-2012, 05:40 PM   #4
Moderator Emeritus
 
MtnGuy's Avatar
 
Join Date: Sep 2008
Location: Shenandoah Valley
Posts: 9,274
Since you bought a 2009 unit, I presume that it was used. You have no idea what kind of water was in the tank before, or if the tank had been properly maintained. As a minimum, I would sanitize the tank. There a number of threads on here on how to do that. Check out post #6 and my post #8 here: Got sick from drinking old water in tank?
__________________

Chap , DW Joy, and Fur Baby Sango
2017 F350 Lariat CCSB, SRW, 4x4, 6.7 PS
2017 Grand Design Reflection 337RLS
MtnGuy is offline   Reply With Quote
Old 09-17-2012, 08:30 AM   #5
Junior Member
 
Join Date: Sep 2012
Posts: 15
Thanks for the ideas, guys. I'm gonna sanitize the tank.
__________________
2004 GMC Safari XLE
2009 Flagstaff 18FBRS MicroLite
sidecar is offline   Reply With Quote
Old 09-17-2012, 08:37 AM   #6
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by sidecar
Thanks for the ideas, guys. I'm gonna sanitize the tank.
Don't forget to remove water filter before sanitizing if it has one ..... which may be the problem all together (old water filter).
Then replace with new when done.

Turbs
__________________

__________________
TURBS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:35 PM.