Reply
 
Thread Tools Display Modes
Old 08-18-2014, 07:46 PM   #1
Junior Member
 
Join Date: Feb 2014
Posts: 6
City water inlet issue.

I have a 2005 salem 27, I used my on board water tank for the first time today , as the pump was running I had water squirting out of the city water inlet. What's going on here.


Sent from my iPad using Forest River Forums
__________________

__________________
mtr727 is offline   Reply With Quote
Old 08-18-2014, 08:26 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Remove screen at water inlet and push check valve in and try to resit it......
Attached Thumbnails
Click image for larger version

Name:	city water inlet Check-valve-seated.jpg
Views:	62
Size:	106.8 KB
ID:	60875  
Attached Images
 
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 08-18-2014, 08:42 PM   #3
Junior Member
 
Join Date: Feb 2014
Posts: 6
Thanks, I'll try that.


Sent from my iPad using Forest River Forums
__________________
mtr727 is offline   Reply With Quote
Reply

Tags
water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:09 AM.