Reply
 
Thread Tools Display Modes
Old 08-16-2014, 06:18 PM   #171
Member
 
Join Date: May 2013
Location: Lander, Wyoming
Posts: 80
My thanks to everyone in this thread. I got my 2013 Rockwood 2703 in June of last year and by the time I got the solar system on it was early July before I got it out. I started noticing odors about the fourth trip out and then in September, it got really bad. I tried everything that everyone else has and still no solution. I was dumping the black water every trip until someone said I should let it get 3/4 full first so I tried that but no difference. Higher temperatures in the trailer made it worse. Tried three doses of the drop in deodorants, checked water levels, etc. Yesterday evening, I had to leave the trailer for fear of being asphyxiated overnight. Came home and got up early this morning to go back and get it off the mountain. Came back got on this forum and noticed the headline on the Dometic 300s. That what I've got. I'll be calling Dometic Monday morning. Thanks again to everyone!
__________________

__________________
wyoman is offline   Reply With Quote
Old 08-16-2014, 10:28 PM   #172
Senior Member
 
Slympicins's Avatar
 
Join Date: Dec 2013
Location: Sevierville
Posts: 761
Your very welcome. We are all here to help.


Sent from my iPhone using Forest River Forums
__________________

__________________
Chuck and Joanne
2014 Flagstaff Super Lite Classic 27RLWS Emerald
2013 Dodge 2500 4x4 Laramie Crew
Equal-i-zer 1200/12,000 4-point WDH
Slympicins is offline   Reply With Quote
Old 08-22-2014, 02:45 PM   #173
Member
 
Join Date: May 2013
Location: Lander, Wyoming
Posts: 80
Final Chapter - I hope

Called Diane at Dometic on Monday the 19th. Got the new toilet on Thursday the 21st. Took out the old unit and put in the new one in about 40 minutes. Couldn't see the problem with the old unit. I removed the rim from the base and...Do that. You'll see the problem! As already noted: Take it easy when you take the old unit out! No tipping or tilting if the cavity feels full.
__________________
wyoman is offline   Reply With Quote
Old 09-04-2014, 06:48 PM   #174
Junior Member
 
Join Date: Sep 2014
Location: Virginia
Posts: 11
2013 Salem. Toilet has sporadically stunk since new regardless of how much chemical I added. Found this site that led me to identify the Dometic 300 in my TT. Called Dometic yesterday and they are sending a new, redesigned 300 to my house via UPS. Should have it tomorrow. Told me that the 300's made before 9/13 were a real problem. Wouldn't have known what to do without the benefit of this forum. My dealer was deaf, dumb and blind and it feel it is through no fault of his own.
__________________
skacatz is offline   Reply With Quote
Old 09-04-2014, 09:55 PM   #175
Senior Member
 
Slympicins's Avatar
 
Join Date: Dec 2013
Location: Sevierville
Posts: 761
Dometic model 300 odor problem and replacement

We bought our 2014 and found the 300 was one of the older ones. Called Dometic and I installed it. My dealer still has no idea what happened even after I told them exactly what was happening. It happens.


Sent from my iPhone using Forest River Forums
__________________
Chuck and Joanne
2014 Flagstaff Super Lite Classic 27RLWS Emerald
2013 Dodge 2500 4x4 Laramie Crew
Equal-i-zer 1200/12,000 4-point WDH
Slympicins is offline   Reply With Quote
Old 09-06-2014, 08:31 PM   #176
Junior Member
 
Join Date: Aug 2014
Posts: 18
Love this forum I had the dreaded stink bomb in my 2014 Heritage Glen after the first trip is smelled awful I sent and email to Diane Staman and within a few days I had my new toilet on the door step hats off to Dometic great customer service. And by they way keep that thing upright on the way out of the trailer. I tiled in once it was out in the yard and it was full of pee....
__________________
fatjack is offline   Reply With Quote
Old 09-06-2014, 08:40 PM   #177
Senior Member
 
BooBoo23's Avatar
 
Join Date: Apr 2014
Location: West Atlanta Metro
Posts: 695
I called Diane to see if the Model 300 in my TT was a defective toilet. I gave her the serial # and she said it was made in October 2013 (44th week) and they had corrected the problem in September so she said I should be OK but if I have any problems to let her know. She said the toilet has a 2 year warranty.
__________________
2014 Palomino Puma 25RS
2011 F-150 Super Crew XLT
Days camped in 2014 - 23 Camped 2015 - 47
Camped 2016 - 58 done - 13 more planned so far
2017 - 14 nights reserved
BooBoo23 is offline   Reply With Quote
Old 09-06-2014, 08:47 PM   #178
Member
 
Join Date: Jul 2014
Posts: 41
Hi all,

Just checking back in... On my 2014 FR3, in July 2014, I had my Dometic 300 toilet replaced with the newer Dometic 300 under warranty and wanted to let everyone know that it has been a few weeks (it is now Sep 2014) and one long trip plus a couple of short trips and the new one is working great! I echo what others have said, the dealers won't believe you, and may not even be able to see the problem (but don't tilt the thing on the way out the door or you will have a mess), and Dometic customer service is terrific.


Sent from my iPad using Forest River Forums
__________________
Z
2014 FR3 30DS
Z Maze is offline   Reply With Quote
Old 09-06-2014, 09:55 PM   #179
Senior Member
 
Wa11y757's Avatar
 
Join Date: Sep 2014
Posts: 169
They were really nice and helpfull for me as well. I called before we even took our first trip and asked for a new one because she confirmed that my serial number was one of the affected ones. But she could not do anything under warranty until it leaked. So 2 trips later......there was the stuff in the clam shell.


2014 Wildwood X-lite 195bh......Happy camping.
__________________
Wa11y757 is offline   Reply With Quote
Old 09-07-2014, 10:50 PM   #180
Member
 
Zoeneens's Avatar
 
Join Date: Aug 2014
Posts: 54
Interesting. I am new to RV living. As some already know, been a steep learning curve.p for me. Anyhow, I have the dometic toilet in the forest River Cedar Creek Cottage CCK 2015. After plugging up the toilet, which I fixed with all the help from this great forum......after 18 days a strong odor happens randomly....but my control panel levels read that the black tank is still low to empty. Can you add another packet of the "treatment"...or just do it only when the tank is emptied?
__________________

__________________
Zoeneens is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:45 PM.