Thread Tools Display Modes
Old 05-05-2015, 12:44 AM   #11
David & Conrad Foxx
FoxxLandArk's Avatar
Join Date: Jan 2015
Location: Chicago
Posts: 45
We have an Atwood tankless HW heater, we had problems getting it to light, staying lit, and producing any hot water at all! Then we found out quite by accident that it was the gas regulator!!! The stove and furnace worked fine, but the water heater wouldn't work until the gas regulator got replaced by the gas company when we parked at the campgrounds for the season and they brought out a larger 120 pound tank. Now we have more hot water then you could ever ask for.

FoxxLandArk is offline   Reply With Quote
Old 05-06-2015, 07:19 AM   #12
Senior Member
muddyrode's Avatar
Join Date: Aug 2013
Location: SE Iowa
Posts: 310
ok here is what we found first the ground wire for the red power light was off
the there was another wire to the flow sensor that was not making contact , got it to light and run but still no hot water or pressure in RV and if on running on the pump it would just rum and never shut of or build pressure with everything shut off that ended up being the freeze sensor thinking it was below 32 degrees so the thank would just circulate with in itself so we just upluged that now every thing seems to work fine well see this weekend
thanks to all

2012 wildcat sterling 32RL
2013 3500HD DRW Silverado Duramax
muddyrode is offline   Reply With Quote
Old 05-06-2015, 07:26 AM   #13
Senior Member
Oakman's Avatar
Join Date: Jul 2007
Location: Jefferson County, MO
Posts: 4,687
Thanks for coming back with an update. Here's hoping the rest of your season is trouble free.

Bob and Joyce
2013 CC Silverback 29RL
2010 Ford F250 XL Crew Cab 6.4 liter diesel
ATU Local 788
Oakman is online now   Reply With Quote
Old 05-06-2015, 03:59 PM   #14
Senior Member
15berkxl's Avatar
Join Date: Mar 2015
Location: Mishawaka
Posts: 563
Originally Posted by Mmnsc View Post
Have ypu tried pressing the reset button. When you look into the water heater, on the left side towards the back is a little white round switchthat has a button on the front. Try pressing that. It should lite after you reset the high limit switch.

Sent from my iPhone using Forest River Forums

I had that problem first trip out. Ended jumping out high limit for remainder of trip leaving only low limit in play. Got tired having to go outside to reset every time using hot water. Worked fine after that.

15berkxl is offline   Reply With Quote

heater, light, tank, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:18 AM.