Reply
 
Thread Tools Display Modes
Old 04-19-2015, 05:21 PM   #1
ddd
Junior Member
 
Join Date: Apr 2015
Posts: 3
Girard tankless hot water heater

Hi. We had a Girard tankless hot water heater installed a month ago. Last week while the trailer (2012 Rockwood Ultralite 2907SS) was in for service, they replaced the magnet switch stating it was not working correctly. The hot water worked fine last night, but this morning we cannot get any hot water. The fan is turning on, but the burner is not igniting. Gerard tech support is closed until Monday and we are on the road heading to Disney with 4 kids. REALLY need hot water (despise bath houses). I have read and read all info and we are still stuck. LED diagnostic light not lighting up, propane full and working to stove, heater, Etc. Unable to view flame. Would appreciate any help...thanks! Signed...very frustrated Mom
__________________

__________________
ddd is offline   Reply With Quote
Old 04-19-2015, 05:56 PM   #2
Senior Member
 
captnrick3's Avatar
 
Join Date: Feb 2015
Location: Santee, CA
Posts: 510
Quote:
Originally Posted by ddd View Post
Hi. We had a Girard tankless hot water heater installed a month ago. Last week while the trailer (2012 Rockwood Ultralite 2907SS) was in for service, they replaced the magnet switch stating it was not working correctly. The hot water worked fine last night, but this morning we cannot get any hot water. The fan is turning on, but the burner is not igniting. Gerard tech support is closed until Monday and we are on the road heading to Disney with 4 kids. REALLY need hot water (despise bath houses). I have read and read all info and we are still stuck. LED diagnostic light not lighting up, propane full and working to stove, heater, Etc. Unable to view flame. Would appreciate any help...thanks! Signed...very frustrated Mom
Wish I could help. We have not had any problems with ours to date so no troubleshooting experience. For sure the red power light is on and the control turned up? (I suppose the fan would not run if no power). Looked through all I can find and do not find anything other than possibly the wires were not connected securely when they changed the magnet switch and might have fallen off.
__________________

__________________
2015 Legacy 340KP
2012 Wrangler Sport
captnrick3 is offline   Reply With Quote
Old 04-19-2015, 07:03 PM   #3
ddd
Junior Member
 
Join Date: Apr 2015
Posts: 3
Thanks for your reply. Yes, we checked that power was good. Actually bought a new battery...just to be sure. As soon as we get to Disney tonight, we will double check all connections. We checked them from the front panel, but need to see if there is something we are missing from the back of the unit. Wondering if maybe the fuse is bad? Glad you are "trouble free" with your Girard. We were until they messed with it!
__________________
ddd is offline   Reply With Quote
Reply

Tags
heater, hot water, tank, tankless, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:51 AM.