Reply
 
Thread Tools Display Modes
Old 07-17-2012, 10:44 AM   #1
Junior Member
 
Join Date: Mar 2012
Posts: 6
help with plumbing problems

I need help please. Two problems.
Firstly I have a 2005 Cardinal 34XL fith wheel.
*The water pump keeps cutting in and I have found problem but not sure how to fix it. The pump draws from the holding tank, runs up a line to the filter, through the filter and then on into the supply lines for fawcets, shower etc. So far so good, all this works fine. The problem is, is the water drains back down the line from the filter back to the pump and then the pump kicks in to bring up the pressure. Anyone know how to solve this problem??
*Second problem is at the city connection for water line. There is a check valve of some kind, a neoprene rod with a spring and a neoprene retainer, which is supposed to activate when pressure is applied (I think) and provide a good flow to the trailer. It is not working properly and I am not sure what or how to tale apart to correct problem. Anyone able to advise or direct me on this.
Thanks you,
Paul
__________________

__________________
firelaw is offline   Reply With Quote
Old 07-17-2012, 11:17 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by firelaw
I need help please. Two problems.
Firstly I have a 2005 Cardinal 34XL fith wheel.
*The water pump keeps cutting in and I have found problem but not sure how to fix it. The pump draws from the holding tank, runs up a line to the filter, through the filter and then on into the supply lines for fawcets, shower etc. So far so good, all this works fine. The problem is, is the water drains back down the line from the filter back to the pump and then the pump kicks in to bring up the pressure. Anyone know how to solve this problem??
*Second problem is at the city connection for water line. There is a check valve of some kind, a neoprene rod with a spring and a neoprene retainer, which is supposed to activate when pressure is applied (I think) and provide a good flow to the trailer. It is not working properly and I am not sure what or how to tale apart to correct problem. Anyone able to advise or direct me on this.
Thanks you,
Paul
1) sounds like check valve is stuck.
2) just replace city check valve there is no fixing.

Fix problem 2 and it might fix issue 1
__________________

__________________
TURBS is offline   Reply With Quote
Old 07-17-2012, 11:32 AM   #3
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
The check valve that F1100Turbo is talking about is not the city water (outside inlet) check valve; but the one internal to the water pump. It may have debris in the valve keeping it from closing once there is pressure in the system.

Some pumps have a rebuild-able pump and check valve assembly and others don't. If under warranty, you want a new pump. If not, check to see it it is Shurflo and order a rebuild kit.
Classic Series Water Pump - SHURflo

RV Water Pump Parts - ShurFlow, FloJet, others - PPL Motor Homes

The CHEAP fix is to put one of these between the pump and the water tank.
Check Valve, 1/2" MPT x 1/2" FPT
Attached Files
File Type: pdf Classic Pump - pds-2088-422-144_444_.pdf (192.4 KB, 19 views)
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 07-17-2012, 11:42 AM   #4
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
It sounds like you have only one problem...the check valve on the city water connection isn't holding. Water leaks out the city connection and the pump then runs to build the pressure back to setpoint. The city connection with check valve needs to be replaced.

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 07-17-2012, 12:22 PM   #5
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Quote:
Originally Posted by firelaw View Post
*Second problem is at the city connection for water line. There is a check valve of some kind, a neoprene rod with a spring and a neoprene retainer, which is supposed to activate when pressure is applied (I think) and provide a good flow to the trailer. It is not working properly and I am not sure what or how to tale apart to correct problem. Anyone able to advise or direct me on this.
Thanks you,
Paul
When you say this is not working properly what do you mean? Is water leaking out and running down the side of the camper when you are running on internal water? If so, are you SURE that the pump is leaking back into the fresh tank?

If the city water check valve is leaking, you will experience cycling of the water pump also. It may be your ONLY problem as both Dave and Turbo suggested and there is nothing wrong with your water pump.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:23 AM.