Reply
 
Thread Tools Display Modes
Old 09-16-2012, 12:19 AM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 3
Hot water heater won,t light on gas.

My hot water heater won't light on gas. I don't believe that gas is even at the ignition point. Works fine on electric. I just purchases this 2012 38 foot Sandstorm toy-hauler. It used to light just fine. I turn the switch to off at the hot water tank and turn the switch on in the trailer. I do have gas and the tank is full of water. Stove lights just fine in the kitchen any ideas?

I am going to check voltages tomorrow at the solenoids, any more ideas?
__________________

__________________
Del_Turner is offline   Reply With Quote
Old 09-16-2012, 12:22 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Del_Turner
My hot water heater won't light on gas. I don't believe that gas is even at the ignition point. Works fine on electric. I just purchases this 2012 38 foot Sandstorm toy-hauler. It used to light just fine. I turn the switch to off at the hot water tank and turn the switch on in the trailer. I do have gas and the tank is full of water. Stove lights just fine in the kitchen any ideas?
Hey del try this ....... .
Turn off both propane tanks.
The very very slowly turn them on and try that.
You may have popped the opd valves
__________________

__________________
TURBS is offline   Reply With Quote
Old 09-16-2012, 12:26 AM   #3
Member
 
Frank4's Avatar
 
Join Date: Nov 2011
Location: Waco tx
Posts: 57
Had a similar issue and looked and looked found out it was just a blown fuse. Water heater worked fine on electric but nothing happened when I attempted to use gas. Check the fuses it took me a couple of tries to find it but that's all it was
__________________
Frank4 is offline   Reply With Quote
Old 09-16-2012, 12:55 AM   #4
Junior Member
 
Join Date: Sep 2012
Posts: 3
I tried that and nothing. Thanks.
__________________
Del_Turner is offline   Reply With Quote
Old 09-16-2012, 12:56 AM   #5
Junior Member
 
Join Date: Sep 2012
Posts: 3
Fuses are good. Thanks.
__________________
Del_Turner is offline   Reply With Quote
Old 09-16-2012, 10:33 AM   #6
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Do you hear it clicking when trying to light ?
__________________
TURBS is offline   Reply With Quote
Old 09-16-2012, 03:36 PM   #7
ARLO
 
Join Date: Oct 2008
Location: N Chili, NY
Posts: 557
no heat

Had this happen to me last month... This could be a bad thermostat. If you open the door, yhere should be two rubber plugs on the heater.they cover the resets. If you push them simultaneously, it may reset...
__________________

__________________
rlocicero is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:33 AM.