Reply
 
Thread Tools Display Modes
Old 05-20-2012, 04:15 PM   #1
Junior Member
 
Join Date: May 2010
Posts: 11
Shurflo pump keeps running

My pump keeps running. I have water pressure, checked for leaks @ water heater, at pump, faucets, drain lines and between the lines. Can not find any leak. I did find a very slow drip @ the connections to the hot water heater out. I tried tighting it and I turned off all the valves to the hot water heater. Pump still runs. It builds up pressure then runs quietly and wont kick off. Do I need to take the front of the pump off to check for fowling or air pockets. Any thoughts or something I missed
__________________

__________________
dingo is offline   Reply With Quote
Old 05-20-2012, 04:20 PM   #2
Senior Member
 
BlakeB's Avatar
 
Join Date: Apr 2012
Location: Iowa
Posts: 404
Mine was doing that and I noticed the water wasnt turned up high enough.
__________________
TT = 2014 Palomino Solaire Eclipse 318TSBHK
TV = 2014 Ram 2500 Big Horn 6.4L V8
Pit Crew: DW (Robin)
Kids: 3yo DD (Riley), another DD cookin (Kennedy)
Security: 5yo Boxer (Sasha), 14yo yorkie (Porter)...he was married in
BlakeB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:23 PM.