Reply
 
Thread Tools Display Modes
Old 08-03-2015, 06:15 AM   #1
Senior Member
 
mduff's Avatar
 
Join Date: Aug 2012
Posts: 178
Suburban Water Heater - Normal Operation?

Recently noted our Suburban water heater (SW6 DE) when on electric, cycling at approximately 5 minute intervals, and for a brief period (40 seconds). We can hear a 'hissing' noise when this occurs, and at times accompanied by a 'whistle' at the end of the cycle period. The unit produces hot water. We do not recall from previous camping trips the frequent cycling when on electric. Operating on propane is as expected, the unit fires occasionally to maintain the water temperature, and more frequently if the water is being used. Is the electric operation normal? Could the temperature (hi/low) switch be faulty or going bad?

Thanks
Mike


Sent from my iPad using Forest River Forums
__________________

__________________
Mike and Brenda

TV - 2013 Silverado 1500, 5.3L
TT - 2012 Wildwood 26 TBSS
mduff is offline   Reply With Quote
Old 08-03-2015, 06:46 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,485
Sounds like it's working fine

TURBS
08 duramax tuned n modded
2011 32bhok Sabre
2015 camping "24 nights"
TURBS is offline   Reply With Quote
Reply

Tags
heater, suburban, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:42 PM.