Reply
 
Thread Tools Display Modes
Old 06-17-2016, 09:02 PM   #1
Junior Member
 
Williamson5's Avatar
 
Join Date: Mar 2016
Posts: 22
SW6-D Suburban water heater....FIXED!!

Our water heater suddenly quit working in our new Cruise Lite. I noticed that it wasn't clicking when the gas valve opened. First I thought bad ignition, but I didn't have power to it. Next was the board ( under the bed by the water heater with a plastic cover over it). Sure enough, power came but didn't go out the board. So since its 3 months old I thought I would see if the dealer would just send me one so I didn't have to drag it 2 1/2 hrs for them to find what I already knew. As I guessed nope...have to look it. I understand. So for $60 I just ordered it myself. Ahh hot water again!! Maybe this will help somebody or maybe not. Lol 520814 Suburban Module Board


2010 Ford Expedition EL Limited

2016 Salem Cruise Lite 282QBXL
__________________

__________________
Williamson5 is offline   Reply With Quote
Old 06-17-2016, 09:22 PM   #2
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 6,256
Yes..... thanks for the post!
__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49 / '14 = 74 / '15 = 74 / '16 = 85 / '17 = 110 / '18 = 0; booked = 28
Mr. Dan is offline   Reply With Quote
Reply

Tags
heater, suburban, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:51 AM.