Reply
 
Thread Tools Display Modes
Old 01-10-2013, 09:39 AM   #1
Senior Member
 
mjones12's Avatar
 
Join Date: Sep 2009
Location: Lexington, NC
Posts: 1,823
Tight gray water valve

Just recently the gray water valve on my three-year-old Surveyor has become extremely hard to pull. It's not that it pops free from being fully closed....the entire pull is hard, and it's hard to push back in to close it. Has anyone else experienced this, and what is the suggested fix? Perhaps WD40 on the shaft? Thanks.
__________________

__________________
2018 Coachmen Apex 249 RBS
2010 Silverado LT 5.3 V8


The world is a great book, of which those who never stir from home
read only a page. - St. Augustine
mjones12 is online now   Reply With Quote
Old 01-10-2013, 11:36 AM   #2
Senior Member
 
Twisty's Avatar
 
Join Date: Mar 2012
Posts: 1,138
No WD 40 please.
This is copied from another source
"Remove the 4 bolts. Spread a bit and that whole piece... comes out. Clean it well, clean the inners and lubricate with plumbers grease and then reinstall. Should get it or you have to replace. Be sure to also lube the pull rod with silicone spray."
__________________

__________________
FOR SALE 2014 BOSS 6.2L F350
2012 Surveyor SV264
NW Oregon
Twisty is offline   Reply With Quote
Old 01-10-2013, 12:13 PM   #3
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,158
Quote:
Originally Posted by Twisty View Post
No WD 40 please.
This is copied from another source
"Remove the 4 bolts. Spread a bit and that whole piece... comes out. Clean it well, clean the inners and lubricate with plumbers grease and then reinstall. Should get it or you have to replace. Be sure to also lube the pull rod with silicone spray."
Make sure it is totally empty and you have your nose plugs in place. Gray water tanks smell as bad as black tanks.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 01-10-2013, 12:21 PM   #4
Senior Member
 
Join Date: Dec 2012
Location: Windsor, Ontario, Canada
Posts: 631
I had a problem with my black water valve, last summer. It ended up being the cable. The gray water cable was replaced at the same time. It was the outer sheath of the cable that was cracked or broken.
__________________
Pipeman is offline   Reply With Quote
Old 01-10-2013, 12:55 PM   #5
Senior Member
 
mjones12's Avatar
 
Join Date: Sep 2009
Location: Lexington, NC
Posts: 1,823
Thanks to you all for the help.
__________________
2018 Coachmen Apex 249 RBS
2010 Silverado LT 5.3 V8


The world is a great book, of which those who never stir from home
read only a page. - St. Augustine
mjones12 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:51 AM.