Thread Tools Display Modes
Old 07-25-2013, 11:54 AM   #1
Junior Member
Join Date: Aug 2012
Posts: 7
Waste Valve Cable Problem

There are long cables from T handle to the valves which operate the various valves. The black valve was not working and I determined that the problem was that the cable was so tight that the friction between the wire and the inner portion of the rubber caused the rubber portion to come out from the housing which supports the tee handle. I'm not sure how to refasten this into the handle housing - any suggestions..
texasdude is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:04 AM.