Reply
 
Thread Tools Display Modes
Old 02-18-2013, 06:52 AM   #1
Member
 
Join Date: Jun 2011
Location: Delray Beach, FL
Posts: 34
Question Water heater ?

HI
On my 2011 georgetown 378 I have a SA10 DE Suburban Water Heater. It just stopped working in the Electric mode but works fine on propane.
Fuse is good, all connections are good, reset button has been reset, etc.. Does anyone know how to check for a bad heater element. What the resitsance should be,
Also any ideas what I should check to get it working? The manual is pretty vague
__________________

__________________
Homejames is offline   Reply With Quote
Old 02-18-2013, 07:25 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
I believe there's a troubleshooting manual in the files section upper left hand corner of frf. Right next to user cp.
Take the two wires off the element.
Resistance should be present.
No resistance would be a bad element.


Turbs
__________________

__________________
TURBS is offline   Reply With Quote
Old 02-18-2013, 09:44 AM   #3
Senior Member
 
tncruiser's Avatar
 
Join Date: Aug 2010
Location: east tn.
Posts: 415
did you operate with no water in tank tats a 3 second mistake but a relatively cheap fix
brianj
__________________
liven life in east TN and wherever my
2011georgetown280ve, and
2016 fordexplorer and hemi RAM
take us
tncruiser is offline   Reply With Quote
Old 02-18-2013, 09:56 AM   #4
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Another easy test for element, remove small round cover from element. Turn on heater and probe the two 120 VAC connections, if power is there, element is open if no power circuits before this point are open. Check the thermostat next to the trip button next.
__________________
VinceU is offline   Reply With Quote
Old 02-18-2013, 11:01 AM   #5
Member
 
Join Date: Jun 2011
Location: Delray Beach, FL
Posts: 34
Thanks Everyone I'll let you know what I find
__________________
Homejames is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:10 AM.