Reply
 
Thread Tools Display Modes
Old 07-05-2011, 06:17 PM   #1
Member
 
Join Date: Oct 2010
Posts: 36
water heater problems

hello all, used the hot water tank for the first time this week and had some problems. Just let me say that I did fill the system with water and removed all air, all the valves are in the proper direction and it works great on propane. Problem: put in on hydro and within three to four minutes it pops the breaker. Any ideas, Thanks in advance. 2011 Rockwood 2604
__________________

__________________
bryanne7 is offline   Reply With Quote
Old 07-05-2011, 06:24 PM   #2
Moderator Emeritus
 
MtnGuy's Avatar
 
Join Date: Sep 2008
Location: Shenandoah Valley
Posts: 9,274
What breaker does it throw, the pedestal or the power center breaker ???
__________________

__________________

Chap , DW Joy, and Fur Baby Sango
2017 F350 Lariat CCSB, SRW, 4x4, 6.7 PS
2017 Grand Design Reflection 337RLS
MtnGuy is offline   Reply With Quote
Old 07-05-2011, 06:25 PM   #3
Member
 
Join Date: May 2011
Location: Lords Valley, PA
Posts: 57
You may have a bad element. I had this issue once. Also check the wiring to it and or the thermostat for the temp. I would lean more towards a defective element or broken wire.
__________________
2008 Rockwood 8281ss
2006 Dodge Ram Mega Cab Hemi
Reese 15k Slider
mikegp1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:59 AM.